Bug 147894 - Services (GUI) hangs on attempt to restart vsftpd dameon
Summary: Services (GUI) hangs on attempt to restart vsftpd dameon
Status: CLOSED DUPLICATE of bug 120579
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-12 04:55 UTC by Alex Gearhart
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-16 13:14:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
servicemethods.py with proposed patch (13.95 KB, text/plain)
2005-02-16 12:42 UTC, Nils Philippsen
no flags Details

Description Alex Gearhart 2005-02-12 04:55:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Services (GUI) hangs when I try to restart the vsftpd dameon.  I have
to do a 'force quit' to close it.  However, it does restart the
dameon, but it hangs and doesn't say "successfully restarted" or
something along those lines.  I am able to use it right after I click
restart.  Also the window freezes, but the rest of the OS is normally
useable.

If any further info is needed please let me know.

Version-Release number of selected component (if applicable):

vsftpd-2.0.1-5


How reproducible:
Always

Steps to Reproduce:
1. Open the services gui
2. Scroll down to vsftpd (which is checked as well)
3. Click restart
    

Actual Results:  The window froze and didn't respond.  Had to do a
force quit.

Expected Results:  A "successfully restarted" message.

Additional info:

Comment 1 Alex Gearhart 2005-02-12 05:03:43 UTC
I realize this bug has been brought up, I did an original search and
didn't find anything, but after querying "vsftpd hangs", I saw there
was another report on it.

Comment 2 Radek Vokal 2005-02-15 15:29:35 UTC
Reproduced here .. will look at it closer. Stoping service work just
fine, starting or restarting hangs. 

Comment 5 Nils Philippsen 2005-02-16 12:42:59 UTC
Created attachment 111124 [details]
servicemethods.py with proposed patch

Please put this version of servicemethods.py into
/usr/share/system-config-services (make a backup of the old one first) and try
whether the problem persists.

Comment 6 Radek Vokal 2005-02-16 13:08:56 UTC
Sorry, but the patch doesn't work. Tested on two machines, starting and
restarting of vsftpd service still freezes. 

Comment 7 Nils Philippsen 2005-02-16 13:14:05 UTC
Bummer, I guess I'll have to rethink the whole start/stop/restart/status stuff.
Close/Dupe.

*** This bug has been marked as a duplicate of 120579 ***


Note You need to log in before you can comment on or make changes to this bug.