Bug 147896 - Info for eth0 is lost on reboot, can be updated works until reboot.
Info for eth0 is lost on reboot, can be updated works until reboot.
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
Blocks: 87718
  Show dependency treegraph
Reported: 2005-02-12 00:39 EST by Timothy Payne
Modified: 2008-05-06 20:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 20:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Timothy Payne 2005-02-12 00:39:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020

Description of problem: Data for eth0 is lost on reboot and
 /etc/hosts will not hold name change for system name on reboot.  This
would all happen when the machine was idle with the last kernel, but
after update with the latest kernel it only happens on reboot.

Version-Release number of selected component (if applicable):
FC 3

How reproducible:

Steps to Reproduce: reboot

Actual Results:  No access to the net

Machine # sub: gateway

reinput above data with internet config. wiz. no problem, other than I
have to do it after any reboot.

Expected Results:  Hold the data.

Additional info:

Solved bug: 129914 that is solved but may provide more info for a fix
as it is the same machine.
Comment 1 Bill Nottingham 2005-02-14 13:43:44 EST
Please attach /etc/sysconfig/network-scripts/ifcfg-*.
Comment 2 Timothy Payne 2005-02-14 14:32:52 EST
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
Comment 3 Bill Nottingham 2005-02-14 14:45:16 EST
So, after each reboot, you only have a network route, not a default route?
Comment 4 Timothy Payne 2005-02-15 01:12:00 EST
I don't really understand the question, but the info above is lost on
reboot.  If re input gateway, netmask, ipaddress, it will work.  Also
if a host name is added to the hosts file it to is lost.
Comment 5 Bill Nottingham 2005-02-15 12:39:31 EST
Can you attach a tarball of /etc/sysconfig/networking and

Are you changing your profile at all?
Comment 6 Timothy Payne 2005-02-15 23:33:07 EST
Please advise the command for tar, I don't use it much so I'd like to
get you exactly what you want the first time.

No I don't change my profile, but I can log out then log in as root,
log out and back to user and the connection is not effected.  It just
gets lost on reboot, and I have had it up for 3 + days with no
problem.  Yesterday I logged out of gnome and back in using KDE and
still no problem for the last 24 hrs.
Comment 7 Harald Hoyer 2005-02-16 05:35:16 EST
You might want to remove the directory /etc/sysconfig/networking
completly, just to be sure.
Comment 8 Timothy Payne 2005-02-17 00:58:36 EST
Oh, that was a good idea.  It trashed everything on the machine
connected with the network.  Good thing I didn't dump the trash and
still had the folder to put it back.
Comment 9 Harald Hoyer 2005-02-17 05:24:07 EST
huh? everything, which is important, should be in
/etc/sysconfig/network-scripts and if it isn't, something is completly
Comment 10 Timothy Payne 2005-02-17 13:16:10 EST
Now the OS can find the card but not update the information, I've
tried to update from the CD's but the stupid bug about the gemomerty
of the drive won't let me.  So now nothing works and all of the
information about the apps that use the network is gone so now nothing

So now I will try to recover my data and get another OS that works. 
Close this but as it no longer will apply.  I was using Red Hat since
ver 5 but not any more.
Comment 11 Matthew Miller 2006-07-10 18:19:20 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 12 Bug Zapper 2008-04-03 11:52:34 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 13 Bug Zapper 2008-05-06 20:06:29 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:

Note You need to log in before you can comment on or make changes to this bug.