Bug 1478974 - x2go killed by systemd
x2go killed by systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: x2goserver (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
https://bugs.x2go.org/cgi-bin/bugrepo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 11:33 EDT by Neal Becker
Modified: 2018-03-13 13:15 EDT (History)
4 users (show)

See Also:
Fixed In Version: x2goserver-4.0.1.22-2.fc27 x2goserver-4.0.1.22-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-06 12:18:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2017-08-07 11:33:23 EDT
Description of problem:

On f26, systemd now kills sessions by default when user logs out.  Since the whole point of x2go is to suspend/resume, it should be packaged to avoid this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Orion Poplawski 2017-08-09 22:05:04 EDT
And how should it accomplish this?  At the moment I'm guessing that x2goruncommand should run "loginctl enable-linger".  Could you try adding that and see what happens?  I'm not able to reproduce this myself for some reason.
Comment 2 Neal Becker 2017-08-10 07:59:37 EDT
I think systemd-run could do it, see example 5:
https://www.freedesktop.org/software/systemd/man/systemd-run.html#Examples
Comment 3 Norman Gaywood 2017-11-06 20:51:43 EST
According to:

https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1198

this should be fixed in x2goserver (4.0.1.21)

with:

loginctl enable-linger

in /usr/bin/x2gostartagent

Could a new Fedora 26 package be built with this update?
Comment 4 Fedora Update System 2017-11-09 21:19:22 EST
x2goserver-4.0.1.21-1.fc26 nx-libs-3.5.0.33-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8d369659cb
Comment 5 Fedora Update System 2017-11-09 21:19:36 EST
x2goserver-4.0.1.21-1.fc27 nx-libs-3.5.0.33-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c4aa0e01
Comment 6 Fedora Update System 2017-11-09 21:19:45 EST
x2goserver-4.0.1.21-1.el6 nx-libs-3.5.0.33-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1ef5f8615b
Comment 7 Fedora Update System 2017-11-09 21:19:53 EST
x2goserver-4.0.1.21-1.fc25 nx-libs-3.5.0.33-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5c350e9cf1
Comment 8 David Jansen 2018-02-19 09:14:11 EST
Any news on this? I ran into this same issue on F27, and after some searching, I found this bug report, but the version x2goserver-4.0.1.21-1 mentioned here doesn't seem to be in updates or updates-testing.
Comment 9 Norman Gaywood 2018-02-23 00:16:42 EST
The update to fix this still seems to be in bodhi and has not been pushed to updates-testing. I don't know enough to know why.

I installed the upstream repo and updated that way:

http://packages.x2go.org/fedora/x2go.repo
Comment 10 Fedora Update System 2018-02-23 09:55:24 EST
x2goserver-4.0.1.21-1.fc27 nx-libs-3.5.0.33-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c4aa0e01
Comment 11 Fedora Update System 2018-02-23 16:08:02 EST
nx-libs-3.5.0.33-4.fc27 x2goserver-4.0.1.22-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c4aa0e01
Comment 12 Fedora Update System 2018-02-23 16:09:26 EST
nx-libs-3.5.0.33-4.fc26 x2goserver-4.0.1.22-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8d369659cb
Comment 13 Fedora Update System 2018-02-24 15:01:04 EST
nx-libs-3.5.0.33-4.fc26, x2goserver-4.0.1.22-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8d369659cb
Comment 14 Fedora Update System 2018-02-24 15:32:09 EST
nx-libs-3.5.0.33-4.fc27, x2goserver-4.0.1.22-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c4aa0e01
Comment 15 Norman Gaywood 2018-02-28 20:35:59 EST
On Fedora 27 it seems that enable-linger does not work as an ordinary user which is required for x2goserver keep sessions alive.

Inside an x2go session:

$ loginctl enable-linger 
Failed to look up user 62: No such process

and (as root) "loginctl show-user ngaywood" shows:

Linger=no

As root I can:

loginctl enable-linger ngaywood

and Linger will be set.

This used to work in Fedora 26

x2goserver-4.0.1.22-0.0x2go1.1.git20180204.1197.main.fc27.x86_64
Comment 16 Fedora Update System 2018-03-06 12:18:39 EST
nx-libs-3.5.0.33-4.fc27, x2goserver-4.0.1.22-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2018-03-13 13:15:00 EDT
nx-libs-3.5.0.33-4.fc26, x2goserver-4.0.1.22-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.