Bug 147899 - Quoted characters off by one
Quoted characters off by one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 06:50 EST by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 11:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot demonstrating the problem (35.55 KB, image/png)
2005-02-12 06:50 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2005-02-12 06:50:48 EST
Description of problem:
The > in quoted text is incorrectly positioned - it is one character before the
signature or where text is typed. This means that the > will re-appear if it has
been deleted and a return entered.

Version-Release number of selected component (if applicable):
2.1.5-1

How reproducible:
Always

Steps to Reproduce:
1. Click on reply to an email
2. Delete some text and enter a carriage return for some whitespace
3.
  
Actual results:
The > returns

Expected results:
White space should be there

Additional info:

Screenshot attached to demonstrate the problem

Using gtkhtml3-3.5.6-2
Comment 1 Paul F. Johnson 2005-02-12 06:50:48 EST
Created attachment 111025 [details]
Screenshot demonstrating the problem
Comment 2 Daniel Malmgren 2005-02-13 12:22:31 EST
I confirm this. It is really irritating. It's not always off by one
though, it sometimes gets off by more. It's like the outer left part
of the message window isn't redrawn like it should (?).
Comment 3 Daniel Malmgren 2005-02-14 12:21:32 EST
Played around a bit more today. It seems that I was right in my
suspicion, the text area isn't redrawn as it should. Scrolling down
the text area and then up again everything looks as it should.
Comment 4 Dave Malcolm 2005-02-14 12:33:41 EST
Many thanks for the updated information.

As a temporary workaround, I've been switching to HTML composition
mode (which doesn't have this bug) when composing replies, then
switching back to text mode before sending the mail (distasteful but
effective!)

Looks like this has been reported upstream here:
http://bugzilla.ximian.com/show_bug.cgi?id=72516
Comment 5 Dave Malcolm 2005-02-14 13:35:05 EST
OK, it's tracked upstream here:
http://bugzilla.ximian.com/show_bug.cgi?id=72399

It's been fixed in upstream CVS, so should be fixed in the next
tarball release.
Comment 6 Daniel Malmgren 2005-03-04 07:59:55 EST
Yep, this works fine now, after upgrading gtkhtml3 to 3.5.7. I guess
this bug could be closed now...
Comment 7 Dave Malcolm 2005-03-04 11:06:20 EST
Resolving: fixed in Rawhide

Note You need to log in before you can comment on or make changes to this bug.