Bug 1478991 - Third-Party Software Source cannot be enabled using GNOME Software
Third-Party Software Source cannot be enabled using GNOME Software
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
27
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1440331
  Show dependency treegraph
 
Reported: 2017-08-07 12:28 EDT by AsciiWolf
Modified: 2017-11-18 07:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-18 07:02:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Enable Third-Party Software Source?" dialog screenshot (63.65 KB, image/png)
2017-08-07 12:28 EDT, AsciiWolf
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 786038 None None None 2017-08-09 06:18 EDT

  None (edit)
Description AsciiWolf 2017-08-07 12:28:34 EDT
Created attachment 1310174 [details]
"Enable Third-Party Software Source?" dialog screenshot

Description of problem:
If you try to install a H.264 codec or something from RPM Fusion or another third-party repository using GNOME Software for a first time, an "Enable Third-Party Software Source?" dialog is shown. However, clicking on the "Enable and Install" button does nothing.

Version-Release number of selected component (if applicable):
gnome-software-3.24.3-1.fc26

How reproducible:
Every time.

Steps to Reproduce:
1. Run GNOME Software.
2. Try to install the H.264 add-on.
3. Click on "Enable and Install".

Actual results:
Nothing happens.

Expected results:
The third-party repository is enabled and the package is installed.

Additional info:
Clean Fedora 26 amd64 install.
Comment 1 AsciiWolf 2017-09-13 09:18:50 EDT
Still the same issue in Fedora 26 with the latest updates.
Comment 2 AsciiWolf 2017-10-02 18:06:53 EDT
Still an issue in GNOME 3.26 on Fedora 27, but it is now possible to click on the "Enable and Install" button. However, clicking the button displays a "repo already enabled" error message and installation is aborted.
Comment 3 AsciiWolf 2017-10-27 08:58:10 EDT
It looks like it is now partially working in Fedora 27! I still cannot install the H.264 add-on, but I can now browse and install the RPM Fusion packages. However, some of the packages (for example Steam) still show the "Enable Third-Party Software Source?" dialog (although the RPM Fusion repos are already enabled) and then fail to install with "Unable to install <package name> as not supported" error message.

This is a journal log related to the Steam installation:
localhost.localdomain gnome-software[1826]: failed to call gs_plugin_app_install on packagekit: installing not available
localhost.localdomain gnome-software[1826]: running install with refine-flags=require-origin with failure-flags=use-events,fatal-auth with timeout=60 on plugin=steam on apps system/package/rpmfusion-nonfree-26/desktop/steam.desktop/* took 1ms
Comment 4 AsciiWolf 2017-10-30 09:52:50 EDT
That's weird. I have tried it one more time and this time, all packages from RPM Fusion were showing the error I mentioned above, but installed without any issues few seconds after the error. Only one packages did not install - the Steam one. After a reboot, the error message disappeared for other packages except Steam.
Comment 5 AsciiWolf 2017-11-18 07:02:16 EST
It looks like that this issue has been fixed in Fedora 27, except for H.264 (#1440331) which is probably a different issue.

Note You need to log in before you can comment on or make changes to this bug.