Bug 1478997 - check_nrpe doesn't work after Fedora 26 upgrade
check_nrpe doesn't work after Fedora 26 upgrade
Status: CLOSED DUPLICATE of bug 1470684
Product: Fedora
Classification: Fedora
Component: nagios-plugins (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen John Smoogen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-07 12:44 EDT by Gerhard Wiesinger
Modified: 2017-08-07 13:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 13:31:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerhard Wiesinger 2017-08-07 12:44:28 EDT
Description of problem:
CHECK_NRPE: Error - Could not complete SSL handshake with 192.168.0.x

Version-Release number of selected component (if applicable):
nagios-plugins-nrpe-3.1.1-1.fc26.x86_64

How reproducible:
Connect to remote host via NRPE

Steps to Reproduce:
1. run check_nrpe on Fedora 26
2.
3.

Actual results:
CHECK_NRPE: Error - Could not complete SSL handshake with 192.168.0.x

Expected results:
Connect possible

Additional info:
Seems to be a known problem with openssl 1.1
https://stackoverflow.com/questions/20520334/check-nrpe-error-could-not-complete-ssl-handshake
https://github.com/NagiosEnterprises/nrpe/issues/113		
https://github.com/NagiosEnterprises/nrpe/issues/113#issuecomment-311052948
Comment 1 Stephen John Smoogen 2017-08-07 13:31:22 EDT
Please test the version that is in updates-testing and if it works please give it positive karma in https://bodhi.fedoraproject.org/updates/FEDORA-2017-47d1a274d4
Comment 2 Stephen John Smoogen 2017-08-07 13:31:52 EDT

*** This bug has been marked as a duplicate of bug 1470684 ***

Note You need to log in before you can comment on or make changes to this bug.