Bug 147900 - Icons missing from panel drawers
Summary: Icons missing from panel drawers
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-12 11:57 UTC by Paul F. Johnson
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: gnome-panel-2.10.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 13:47:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing icons from gnomepanel (49.10 KB, image/png)
2005-02-12 11:57 UTC, Paul F. Johnson
no flags Details
Application Launcher bug (22.19 KB, image/jpeg)
2005-02-13 16:50 UTC, Naadir Jeewa
no flags Details

Description Paul F. Johnson 2005-02-12 11:57:20 UTC
Description of problem:
A large number of icons are missing from panel drawers. If I edit the
properties, the icons are still in the iconbox, but not on the drawers. If I
alter the panel icon to something else and then back to the correct icon, all is
fine.

Version-Release number of selected component (if applicable):
2.9.91-2

How reproducible:
Always

Steps to Reproduce:
1. Create a drawer under a previous version of gnomepanel
2. Update
3.
  
Actual results:
Some icons vanish

Expected results:
All icons should remain

Additional info:

Screenshot attached showing what happens

Comment 1 Paul F. Johnson 2005-02-12 11:57:21 UTC
Created attachment 111026 [details]
Missing icons from gnomepanel

Comment 2 Naadir Jeewa 2005-02-13 16:50:48 UTC
Created attachment 111040 [details]
Application Launcher bug

Even if you create a new drawer, when the drawer is first used in a session, I
get a message saying icons cannot be found

In addition, icons are also missing on the application launcher applets (if
those launchers refer to a menu), despite appearing on the Applications menu.

My suspicion is that this is to do with gnome-vfs2 more than it is to do with
gnome-panel.

Version-Release number of selected component (if applicable):
gnome-panel-2.9.91-2
gnome-vfs2-2.9.91-1

Steps to Reproduce:
1. Create an application launcher using an Applications menu, or create an
application launcher on a drawer.

Comment 3 Mark McLoughlin 2005-02-22 12:18:56 UTC
Yeah, I've seen oddities with icons in rawhide too. I think it might
have something to do with the fact that we use GtkIconTheme now
instead of GnomeIconTheme.

Comment 4 Paul F. Johnson 2005-03-17 15:11:14 UTC
Looks likes it's working in FC4t1 and rawhide (updates 16th March 2005). Can
someone verify it and change the status to closed?

Comment 5 Brian Millett 2005-03-25 01:19:03 UTC
no it is not as of 3/24 rawhide updates.
I have a custom theme of:
clearlooks-deepsky - control
macos-x            - window border
bluecurve          - icons.

Wait!

Ok, so I'm on drugs.  After opening the preferences->theme menu item, the icons
all of a sudden are in the drawer.  Go figure.  I'll see if this lasts between
boots.

Comment 6 Brian Millett 2005-03-25 03:04:02 UTC
well, they did not persist.  After chosing the preferences->theme menu ite, the
gam_server process whas taking up to 10% cpu cycles.

Comment 7 Paul F. Johnson 2005-03-27 13:54:12 UTC
Still seeing the same problem here. Restarting the gam_server makes no
difference, I still can't see anything on gnome panel drawers.

Using

gnome-panel-2.10.0-1
gnome-vfs2-2.10.0-2

Comment 8 Mark McLoughlin 2005-04-04 10:56:40 UTC
I'll try and push gnome-panel 2.10.1 to rawhide very soon - I think that may
have a fix

Comment 9 Mark McLoughlin 2005-04-04 13:47:32 UTC
Okay, please re-open if gnome-panel-2.10.1-1 doesn't fix the problem.


Note You need to log in before you can comment on or make changes to this bug.