Bug 147906 - Need to mount more that 8 iso images on Production server
Need to mount more that 8 iso images on Production server
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 09:38 EST by Stephen Lockley
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 13:44:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Lockley 2005-02-12 09:38:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
I need to mount more that 8 iso images on a production server so that
people on the LAN can use them.

The error message is mount: could not find any free loop device

dmesg | grep loop

loop: loaded (max 8 devices)

modinfo loop
filename:       /lib/modules/2.6.10-1.741_FC3/kernel/drivers/block/loop.ko
parm:           max_loop:Maximum number of loop devices (1-256)
license:        GPL
alias:          block-major-7-*
vermagic:       2.6.10-1.741_FC3 686 REGPARM 4KSTACKS gcc-3.4
depends:
srcversion:     C7DA7AB66C05B09B2C38ECF


Version-Release number of selected component (if applicable):
mount

How reproducible:
Always

Steps to Reproduce:
1. Mount more that 8 iso images
2.
3.
    

Actual Results:  mount: could not find any free loop device

Expected Results:  Able to mount iso images

Additional info:

uname -r
2.6.10-1.741_FC3

If not fixed in fc3 will it be fixed in fc4
Comment 1 Florian La Roche 2005-02-13 07:26:37 EST
Works for me by changing the option of the kernel module to
have more loop devices and reloading the kernel module.
Comment 2 Stephen Lockley 2005-02-13 08:26:21 EST
Could you please commands you used?

TIA
Comment 3 Bill Nottingham 2005-02-14 13:44:33 EST
Add 'options loop max_loop=<some number greater than 8>' to
/etc/modprobe.conf.

Note You need to log in before you can comment on or make changes to this bug.