Bug 1479114 - The top ones in drop down list are hidden by the logo banner after re-sized window
Summary: The top ones in drop down list are hidden by the logo banner after re-sized w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.7.z
Assignee: Steve Goodwin
QA Contact: XiaochuanWang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-08 02:34 UTC by XiaochuanWang
Modified: 2018-04-05 09:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The default ui-select selection field had a lower z-index value than the project bar. Consequence: The add to project selection could be partially hidden at small browser viewport size, because it was beneath the project bar. Fix: Make ui-select dropdown field a z-index 1 greater than the project bar Result: Select field will now appear over the project bar if needed.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:28:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
top ones are hidden by the logo banner (53.13 KB, image/png)
2017-08-08 02:34 UTC, XiaochuanWang
no flags Details
drop-down-list-cover-by-pane-header.png (48.85 KB, image/png)
2017-11-01 08:25 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:29:03 UTC

Description XiaochuanWang 2017-08-08 02:34:47 UTC
Created attachment 1310402 [details]
top ones are hidden by the logo banner

Description of problem:
Go to Add-to-Image Deploy Image page, re-size window, make it shot and flat (see screenshot), open the ImageStream drop down list. The top ones are hidden by the header logo banner.

Version-Release number of selected component (if applicable):
OpenShift Master:  v3.6.173.0.5
Kubernetes Master: v1.6.1+5115d708d7

How reproducible:
Always

Steps to Reproduce:
1. Go to Add to Image -> Deploy Image
2. Re-size window, make it shot and flat (see screenshot)
3. Open the ImageStream drop down list

Actual results:
Drop down list open from the upper side. The top ones are hidden by the header logo banner even maximize the window.

Expected results:
Should show the top ones.

Additional info:

Comment 1 openshift-github-bot 2017-09-21 18:03:34 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/ac4c8347da795347701e4ecc3b1870248428fd52
Merge pull request #2134 from sg00dwin/ui-select-bug1479114

Merged by openshift-bot

Comment 3 XiaochuanWang 2017-11-01 08:25:02 UTC
This PR has been merged https://github.com/openshift/origin-web-console/pull/2134

Since latest layout has been changed (on OCP v3.7.0-0.188.0), this issue is still reproduced, please check the screenshot "drop-down-list-cover-by-pane-header.png"

Comment 4 XiaochuanWang 2017-11-01 08:25:32 UTC
Created attachment 1346380 [details]
drop-down-list-cover-by-pane-header.png

Comment 6 Steve Goodwin 2017-12-07 14:51:48 UTC
PR with fix. https://github.com/openshift/origin-web-console/pull/2580

Comment 8 Yanping Zhang 2018-03-05 07:18:50 UTC
Tested on ocp v3.7.36, on Deploy Image page, the image stream tag dropdown list could show normally according window size.
The bug has been fixed, so move it to Verified.

Comment 12 errata-xmlrpc 2018-04-05 09:28:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.