Bug 1479165 - [3.6] ansible_service_broker_image_tag should be set to 3.6 by default instead of latest
[3.6] ansible_service_broker_image_tag should be set to 3.6 by default instea...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity medium
: ---
: 3.6.z
Assigned To: ewolinet
Johnny Liu
:
Depends On:
Blocks: 1484323
  Show dependency treegraph
 
Reported: 2017-08-08 02:10 EDT by Johnny Liu
Modified: 2017-09-05 13:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The default image tag for ansible service now defaults to 'v3.6' rather than 'latest' ensuring that the appropriate release is deployed.
Story Points: ---
Clone Of:
: 1484323 (view as bug list)
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2017-08-08 02:10:19 EDT
Description of problem:
In roles/ansible_service_broker/vars/openshift-enterprise.yml, the following var is set:
__ansible_service_broker_image_tag: latest

It should point v3.6 by default.


Version-Release number of the following components:
openshift-ansible-3.6.173.0.2-1.git.0.f6cbecf.el7.noarch
How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag
Comment 2 Johnny Liu 2017-08-23 04:50:49 EDT
Verified this bug with openshift-ansible-3.6.173.0.7-2.git.0.340aa2c.el7.noarch, and PASS.

[root@openshift-141 ~]# oc project openshift-ansible-service-broker
Now using project "openshift-ansible-service-broker" on server 

[root@openshift-141 ~]# oc get po
NAME                    READY     STATUS    RESTARTS   AGE
asb-3958080670-z5mx2    1/1       Running   0          8m
etcd-1487946270-bpc71   1/1       Running   0          8m

[root@openshift-141 ~]# oc describe po asb-3958080670-z5mx2 | grep Image
    Image:		openshift3/ose-ansible-service-broker:v3.6
    Image ID:		docker-pullable://registry.access.redhat.com/openshift3/ose-ansible-service-broker@sha256:4d5b8059647bca60328f5e5b1307422497409e9ae1c77fdc83503cf911ab1e24
Comment 4 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.