Bug 1479175 - only 70GB block device is available to app pod when 75GB is requested
only 70GB block device is available to app pod when 75GB is requested
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Prasanna Kumar Kalever
Rahul Hinduja
:
Depends On: 1479001
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 02:20 EDT by krishnaram Karthick
Modified: 2017-08-09 00:51 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1479001
Environment:
Last Closed: 2017-08-09 00:47:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 6 Humble Chirammal 2017-08-08 09:30:03 EDT
If 75G is requested, Gluster block command is filled with 75G.
Comment 19 krishnaram Karthick 2017-08-09 00:47:47 EDT
Prasanna and me tried to reproduce the issue and we see that a request to create  75G device is passed by heketi as 70G.

This indicates that the issue is not due to gluster-block but by the was request is sent. We'll have to see if the issue is with the way template is configured or with the heketi. In any case, this need not be tracked at RHGS. This bug shall be closed as not a bug.

[root@dhcp47-57 ~]# oc new-app mongo.json --param=DATABASE_SERVICE_NAME=test-krk --param=VOLUME_CAPACITY=75G

snippet of heketi log:
=======================
[kubeexec] DEBUG 2017/08/09 04:39:41 /src/github.com/heketi/heketi/executors/kubeexec/kubeexec.go:250: Host: dhcp46-11.lab.eng.blr.redhat.com Pod: glusterfs-br2qq Command: gluster-block create vol_bc8159f87fe713da6db71010dca9abe9/blockvol_835a51344be42a1d0b1a3b0efe372246  ha 3 auth enable  10.70.46.11,10.70.47.23,10.70.47.69 70G --json
Result: { "IQN": "iqn.2016-12.org.gluster-block:60e14200-f87c-4eb1-8f9c-b29e7d5d214a", "USERNAME": "60e14200-f87c-4eb1-8f9c-b29e7d5d214a", "PASSWORD": "7cc35794-5450-46ff-b3ec-a04b7e031562", "PORTAL(S)": [ "10.70.46.11:3260", "10.70.47.23:3260", "10.70.47.69:3260" ], "RESULT": "SUCCESS" }
[heketi] INFO 2017/08/09 04:39:41 Created block volume 835a51344be42a1d0b1a3b0efe372246
[asynchttp] INFO 2017/08/09 04:39:41 asynchttp.go:129: Completed job fa72164e6dbe8f56db88624f7995555d in 37.987264117s
[negroni] Started GET /queue/fa72164e6dbe8f56db88624f7995555d
[negroni] Completed 303 See Other in 66.175µs
[negroni] Started GET /blockvolumes/835a51344be42a1d0b1a3b0efe372246
[negroni] Completed 200 OK in 3.025844ms

Note You need to log in before you can comment on or make changes to this bug.