Bug 1479179 - Ctrl-C is not handled by --new-chroot
Ctrl-C is not handled by --new-chroot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 02:31 EDT by Vít Ondruch
Modified: 2018-01-02 05:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-25 16:30:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2017-08-08 02:31:53 EDT
Description of problem:
Ctrl-C is not handled by --new-chroot. I can pres Ctrl+C as I want but nothing happens.


Version-Release number of selected component (if applicable):
$ rpm -q mock
mock-1.4.3-1.fc27.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Ctrl+C does not work.

Expected results:
Ctrl+C works.


Additional info:
This was issue also in mock 1.4.2 AFAIK.
Comment 1 Miroslav Suchý 2017-08-09 04:15:48 EDT
I cannot reproduce.
It works for me during 'dnf install' phase as well during build phase:

...
_scan.py py/mockbuild/plugins/compress_logs.py py/mockbuild/plugins/hw_info.py py/mockbuild/plugins/lvm_root.py py/mockbuild/plugins/mount.py py/mockbuild/plugins/package_state.py py/mockbuild/plugins/pm_request.py py/mockbuild/plugins/root_cache.py py/mockbuild/plugins/selinux.py py/mockbuild/plugins/sign.py py/mockbuild/plugins/tmpfs.py py/mockbuild/plugins/yum_cache.py
^C
[msuchy@dri/~/projects/mock{devel}]130$ ERROR: Exception(/tmp/tito/mock-1.4.3-1.git.2.4b3eabb.fc26.src.rpm) Config(fedora-26-x86_64) 0 minutes 34 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-26-x86_64/result
WARNING: Machine ff7a94b968a7406681de2dd04efbe5cc still running. Killing...
ERROR: Exiting on user interrupt, <CTRL>-C
Comment 2 Vít Ondruch 2017-08-09 04:26:56 EDT
May be I was not descriptive enough :)

~~~
$ mock -r fedora-rawhide-x86_64 shell --unpriv --new-chroot
INFO: mock.py version 1.4.3 starting (python version = 3.6.2)...
Start(bootstrap): init plugins
INFO: selinux disabled
Finish(bootstrap): init plugins
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Start(bootstrap): chroot init
INFO: LVM plugin enabled. Allocated pool data: 26.67%. Allocated metadata: 15.06%.
WARNING: For multilib systems, both architectures of nosync library need to be installed
INFO: calling preinit hooks
INFO: enabled dnf cache
Start(bootstrap): cleaning dnf metadata
Finish(bootstrap): cleaning dnf metadata
INFO: enabled HW Info plugin
Finish(bootstrap): chroot init
Start: chroot init
INFO: LVM plugin enabled. Allocated pool data: 26.68%. Allocated metadata: 15.06%.
WARNING: For multilib systems, both architectures of nosync library need to be installed
INFO: calling preinit hooks
INFO: enabled dnf cache
Start: cleaning dnf metadata
Finish: cleaning dnf metadata
INFO: enabled HW Info plugin
Finish: chroot init
Start: shell
sh: nelze nastavit skupinu procesů terminálu (-1): Inappropriate ioctl for device
sh: žádná správa úloh v tomto shellu
<mock-chroot> sh-4.4$ sfd
~~~

At this stage, I was pressing Ctrl+C as mad, it should cause something like:

~~~
<mock-chroot> sh-4.4$ sfd^C
<mock-chroot> sh-4.4$
~~~

but nothing happens.
Comment 3 Jan Kurik 2017-08-15 02:52:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 4 Miroslav Suchý 2017-12-25 16:30:17 EST
works for me. with F27 and mock 1.4.8.
Comment 5 Vít Ondruch 2018-01-02 05:59:15 EST
It have started to work again ~1 month ago. Not sure what was changed ...

Note You need to log in before you can comment on or make changes to this bug.