This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1479204 - [3.6] The image tag for container-engine should follow OpenShift version instead of hard coded "latest"
[3.6] The image tag for container-engine should follow OpenShift version inst...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.6.z
Assigned To: Steve Milner
Gan Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 02:41 EDT by Gan Huang
Modified: 2017-09-05 13:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The default image tag for ansible service now defaults to 'v3.6' rather than 'latest' ensuring that the appropriate release is deployed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:42:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gan Huang 2017-08-08 02:41:23 EDT
Description of problem:
Currently installer hard code the container-engine image tag to "latest", this is unreliable and confusing to users. We need the ability to tell what the version of container-engine image is being used.


Version-Release number of the following components:
openshift-ansible-3.6.173.0.5-3.git.0.522a92a.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Trigger installation with enabling docker system container


Actual results:
Installer pull "latest" container-engine image for use.

Expected results:
Nowadays container-engine image is from openshift3 repository instead of rhel7 repository, there will be corresponding container-engine image built out for each openshift release, so installer should use a precise image tag for container-engine.

Additional info:
Comment 1 Steve Milner 2017-08-08 14:21:58 EDT
For 3.6 there was a decision made to use latest since it is tech preview only. However this is a fair request. I'll make a PR to limit it to the same tag as the rest of the containers.
Comment 2 Steve Milner 2017-08-08 15:00:31 EDT
PR: https://github.com/openshift/openshift-ansible/pull/5031

In terms of tags for the CentOS and Fedora builds I think Giuseppe and I need to have a discussion to figure out how we can keep these all in sync.
Comment 5 Steve Milner 2017-08-11 12:06:17 EDT
Merged in to 3.6.
Comment 7 Gan Huang 2017-08-23 03:57:22 EDT
Verified with openshift-ansible-docs-3.6.173.0.7-2.git.0.340aa2c.el7.noarch.rpm

Now installer pulls container-engine:v3.6 image by default.
Comment 9 errata-xmlrpc 2017-09-05 13:42:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2639

Note You need to log in before you can comment on or make changes to this bug.