Bug 1479259 - The UseDNS configuration option changed default behaviour between 7.3 and 7.4, this breaks existing configurations until manually corrected [rhel-7.4.z]
The UseDNS configuration option changed default behaviour between 7.3 and 7.4...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openssh (Show other bugs)
7.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jakub Jelen
Stefan Dordevic
Mirek Jahoda
: Regression, ZStream
: 1491840 (view as bug list)
Depends On: 1478175
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 04:30 EDT by Jaroslav Reznik
Modified: 2017-09-15 03:45 EDT (History)
16 users (show)

See Also:
Fixed In Version: openssh-7.4p1-12.el7
Doc Type: Bug Fix
Doc Text:
In Red Hat Enterprise Linux 7.4, the default value of the UseDNS configuration option had been changed to "No". This change prevented OpenSSH from translating IP addresses to host names to be used in server configuration files and access rules of the authorized_keys files. However, it also broke existing installations until manually corrected. With this update, the default value of UseDNS has been changed to "Yes", and the default configuration is compatible with Red Hat Enterprise Linux 7.3 and older installations again.
Story Points: ---
Clone Of: 1478175
Environment:
Last Closed: 2017-09-05 07:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3139201 None None None 2017-08-08 04:30 EDT

  None (edit)
Description Jaroslav Reznik 2017-08-08 04:30:34 EDT
This bug has been copied from bug #1478175 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 8 errata-xmlrpc 2017-09-05 07:25:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2576
Comment 9 Tomas Mraz 2017-09-15 03:45:47 EDT
*** Bug 1491840 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.