This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147928 - Alphabetic sort capability for find
Alphabetic sort capability for find
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: findutils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-13 05:54 EST by Christopher Beland
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 04:48:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2005-02-13 05:54:37 EST
Sometimes it would be handy if "find" could process output for each
directory in alphabetical order, like ls does by default.  Merely
piping to "sort" mixes the output from multiple directories.
Comment 1 Tim Waugh 2005-02-14 04:50:51 EST
Could you give an example of why that might be useful?
Comment 2 Christopher Beland 2005-02-17 11:24:54 EST
If I remember correctly, I was passing the output of find to some script that
needed relative pathnames.  I think I was using it to produce a report sorted by
directory, and I wanted the contents of each directory to be alphabetized,
because otherwise it was too annoying to find any particular file in the listings.
Comment 3 Tim Waugh 2005-02-23 04:48:42 EST
Please submit this request on the https://savannah.gnu.org/projects/findutils
site.  Thanks.
Comment 4 Christopher Beland 2007-08-26 17:08:22 EDT
Done: https://savannah.gnu.org/bugs/index.php?20909

Note You need to log in before you can comment on or make changes to this bug.