Bug 1479297 - Tahoma font rendering broken after upgrade from 25 to 26
Tahoma font rendering broken after upgrade from 25 to 26
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
26
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 05:59 EDT by Mark
Modified: 2017-08-18 11:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 11:06:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Broken Rendering (2.63 KB, image/png)
2017-08-08 05:59 EDT, Mark
no flags Details

  None (edit)
Description Mark 2017-08-08 05:59:01 EDT
Created attachment 1310501 [details]
Broken Rendering

Description of problem:

Since I upgraded from Fedora 25 to 26, the rendering of the Tahoma font as used by wine is broken. Usually, the embedded bitmaps are used to provide a perfect rendering, but now it seems that anti-aliasing is disabled and the embedded bitmaps are ignored. See attachment what it currently looks like - definitely not what you'd expect and very annoying when using Windows-applications under Wine.

Version-Release number of selected component (if applicable):

Not sure as it might be related to the font, freetype or any other font-renderer involved

How reproducible:

Steps to Reproduce:
1. Install wine
2. Run "wine regedit"
3. Observe Font

Actual results:

Ugly rendering as in the attachment

Expected results:

Perfect rendering as in http://www.onecomputerguy.com/images/regedit1.gif

Additional info:
Comment 1 Michael Cronenworth 2017-08-08 09:46:59 EDT
I cannot reproduce the issue.

Can you try with a fresh wine prefix and report if it still renders the same?

WINEPREFIX=~/wine-test regedit
Comment 2 Mark 2017-08-08 09:52:38 EDT
Yes, absolutely identical
Comment 3 Mark 2017-08-08 10:05:35 EDT
UPDATE: when I remove msttcorefonts, it renders as beautiful as ever.

Maybe something changed in the order in which the font dirs are used?
Comment 4 Michael Cronenworth 2017-08-08 11:06:03 EDT
The msttcorefonts package is not a Fedora package so I cannot say. If I had to guess the msttcorefonts no longer render well with freetype.

FYI: We also ship a (optional) Tahoma system font in a package: wine-tahoma-fonts-system
Comment 5 Michael Cronenworth 2017-08-10 10:20:10 EDT
You should check out bug 1470509 to see if it relates to your issue.

"If you prefer the older hinting engine, you can select it by setting environment variable "FREETYPE_PROPERTIES" to "truetype:interpreter-version=35" "
Comment 6 Mark 2017-08-18 11:54:34 EDT
Yes, that's the solution. It's probably, because the fonts shipped with wine have good hinting for the newer engine, but I prefer using the original MS fonts with freetype-world. Excellent, thanks for the solution!

Note You need to log in before you can comment on or make changes to this bug.