Bug 1479318 - Containerized deployment with Ceph nodes deployed via ceph-ansible fails with: CREATE_FAILED Error in CephBase output role_data: resources.ServiceChain.list index out of range
Containerized deployment with Ceph nodes deployed via ceph-ansible fails with...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
urgent Severity urgent
: beta
: 12.0 (Pike)
Assigned To: Giulio Fidente
Alexander Chuzhoy
: AutomationBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 07:03 EDT by Marius Cornea
Modified: 2018-02-05 14:10 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:49:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 491759 None None None 2017-08-08 07:34 EDT
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-15 20:43:25 EST

  None (edit)
Description Marius Cornea 2017-08-08 07:03:34 EDT
Description of problem:
Containerized deployment with Ceph nodes deployed via ceph-ansible fails with: CREATE_FAILED  Error in CephBase output role_data: resources.ServiceChain.list index out of range

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Deploy OSP12:

#!/bin/bash

timeout 100m openstack overcloud deploy \
-r ~/roles_data.yaml \
--templates /usr/share/openstack-tripleo-heat-templates \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
-e /home/stack/virt/network/network-environment.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/nodes_data.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/docker-ha.yaml \
-e /home/stack/docker-osp12.yaml \


Actual results:

2017-08-08 10:42:42Z [overcloud.CephStorageServiceChain.ServiceChain]: CREATE_FAILED  Error in CephBase output role_data: resources.ServiceChain.list index out of range
Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/heat/common/context.py", line 409, in wrapped
    return func(self, ctx, *args, **kwargs)

  File 
2017-08-08 10:42:42Z [overcloud.BlockStorageServiceChain.LoggingGroupsConfig]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:42Z [overcloud.ObjectStorageServiceChain.PuppetConfig]: CREATE_COMPLETE  state changed
2017-08-08 10:42:42Z [overcloud.ControllerServiceChain.ServiceChain.78]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:42Z [overcloud.CephStorageServiceChain]: CREATE_FAILED  Resource CREATE failed: Error in CephBase output role_data: resources.ServiceChain.list index out of range
Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/heat/common/context.py", line 409, in wrapped
    return func(self, ctx, *
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.UpgradeBatchTasks]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.DockerConfig]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.CephStorageServiceChain]: CREATE_FAILED  Error in CephBase output role_data: resources.CephStorageServiceChain.resources.ServiceChain.list index out of range
Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/heat/common/context.py", line 409, in wrapped
    return func(se
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.ServiceServerMetadataHook]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.PuppetStepConfig]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.GlobalConfigSettings]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.ServiceNames]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.ServiceWorkflowTasks]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain.ServiceConfigSettings]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.BlockStorageServiceChain]: CREATE_FAILED  CREATE aborted
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain]: CREATE_COMPLETE  Stack CREATE completed successfully
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.0]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain]: CREATE_FAILED  CREATE aborted
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.33]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.24]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.10]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.6]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.4]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.5]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.17]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.13]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.9]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.34]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.18]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.19]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain.25]: CREATE_COMPLETE  state changed
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain]: CREATE_FAILED  Resource CREATE failed: Error in CephBase output role_data: list index out of range
Traceback (most recent call last):

  File "/usr/lib/python2.7/site-packages/heat/common/context.py", line 409, in wrapped
    return func(self, ctx, *args, **kwargs)

  F
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain.ServiceChain]: CREATE_FAILED  CREATE aborted
2017-08-08 10:42:43Z [overcloud.ComputeServiceChain]: CREATE_FAILED  Resource CREATE failed: Operation cancelled
2017-08-08 10:42:43Z [overcloud.ControllerServiceChain.ServiceChain.55]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:43Z [overcloud.ControllerServiceChain.ServiceChain.71]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:43Z [overcloud.ObjectStorageServiceChain]: CREATE_FAILED  CREATE aborted
2017-08-08 10:42:43Z [overcloud.ControllerServiceChain.ServiceChain.89]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.97]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain]: CREATE_FAILED  CREATE aborted
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.76]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud]: CREATE_FAILED  Resource CREATE failed: Error in CephBase output role_data: resources.CephStorageServiceChain.resources.ServiceChain.list index out of range
Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/heat/common/context.py", line 409, in wr
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.19]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.17]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.77]: CREATE_IN_PROGRESS  state changed
2017-08-08 10:42:44Z [overcloud.ControllerServiceChain.ServiceChain.41]: CREATE_IN_PROGRESS  state changed

 Stack overcloud CREATE_FAILED 

ERROR: Error in CephBase output role_data: list index out of range
ERROR: Error in CephBase output role_data: list index out of range
Heat Stack create failed.
Heat Stack create failed.
Comment 2 Alexander Chuzhoy 2017-08-08 11:36:20 EDT
reproduced.
Comment 7 Alexander Chuzhoy 2017-08-18 11:29:23 EDT
Environment:
openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost.noarch
The reported issue doesn't reproduce.
Comment 11 errata-xmlrpc 2017-12-13 16:49:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.