Bug 1479350 - AVC denials seen while running ipa-nis-integration suite.
AVC denials seen while running ipa-nis-integration suite.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.4
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 08:09 EDT by Sudhir Menon
Modified: 2018-04-10 08:37 EDT (History)
11 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-188.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 08:36:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0763 None None None 2018-04-10 08:37 EDT

  None (edit)
Description Sudhir Menon 2017-08-08 08:09:06 EDT
Description of problem: AVC denials are seen while running ipa-nis-integration test suite.


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-166.el7.noarch
ipa-server-4.5.0-21.el7_4.1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run ipa-nis-integration test suite.

Actual results:
Info: Searching AVC errors produced since 1502190265.07 (Tue Aug  8 16:34:25 2017)
Searching logs...
Running '/usr/bin/env LC_ALL=en_US.UTF-8 /sbin/ausearch -m AVC -m USER_AVC -m SELINUX_ERR -ts 08/08/2017 16:34:25 < /dev/null >/mnt/testarea/tmp.rhts-db-submit-result.fb47zr 2>&1'
----
time->Tue Aug  8 16:35:01 2017
type=USER_AVC msg=audit(1502190301.932:422): pid=32562 uid=28 auid=4294967295 ses=4294967295 subj=system_u:system_r:nscd_t:s0 msg='avc:  received policyload notice (seqno=7)  exe="?" sauid=28 hostname=? addr=? terminal=?'
----
time->Tue Aug  8 16:35:03 2017
type=USER_AVC msg=audit(1502190303.499:426): pid=32562 uid=28 auid=4294967295 ses=4294967295 subj=system_u:system_r:nscd_t:s0 msg='avc:  received policyload notice (seqno=8)  exe="?" sauid=28 hostname=? addr=? terminal=?'
----
time->Tue Aug  8 16:35:03 2017
type=USER_AVC msg=audit(1502190303.576:428): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  received policyload notice (seqno=7)  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
----
time->Tue Aug  8 16:35:03 2017
type=USER_AVC msg=audit(1502190303.576:429): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='avc:  received policyload notice (seqno=8)  exe="/usr/lib/systemd/systemd" sauid=0 hostname=? addr=? terminal=?'
----
time->Tue Aug  8 16:35:04 2017
type=PROCTITLE msg=audit(1502190304.895:434): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1502190304.895:434): arch=c000003e syscall=2 success=no exit=-13 a0=7f07633aff28 a1=0 a2=7f07633aff47 a3=0 items=0 ppid=1 pid=32562 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1502190304.895:434): avc:  denied  { search } for  pid=32562 comm="nscd" name="yp" dev="dm-0" ino=100778817 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:var_yp_t:s0 tclass=dir
----
time->Tue Aug  8 16:35:02 2017
type=PROCTITLE msg=audit(1502190302.733:423): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1502190302.733:423): arch=c000003e syscall=2 success=no exit=-13 a0=7f0762fadf98 a1=0 a2=7f0762fadfb7 a3=0 items=0 ppid=1 pid=32562 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1502190302.733:423): avc:  denied  { search } for  pid=32562 comm="nscd" name="yp" dev="dm-0" ino=100778817 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:var_yp_t:s0 tclass=dir
----
time->Tue Aug  8 16:35:02 2017
type=PROCTITLE msg=audit(1502190302.734:424): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1502190302.734:424): arch=c000003e syscall=49 success=no exit=-13 a0=15 a1=7f0762fade40 a2=10 a3=33 items=0 ppid=1 pid=32562 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1502190302.734:424): avc:  denied  { name_bind } for  pid=32562 comm="nscd" src=958 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:hi_reserved_port_t:s0 tclass=tcp_socket
----
time->Tue Aug  8 16:35:02 2017
type=PROCTITLE msg=audit(1502190302.746:425): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1502190302.746:425): arch=c000003e syscall=49 success=no exit=-13 a0=15 a1=7f0762fade10 a2=10 a3=72 items=0 ppid=1 pid=32562 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1502190302.746:425): avc:  denied  { name_bind } for  pid=32562 comm="nscd" src=959 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:hi_reserved_port_t:s0 tclass=udp_socket
Fail: AVC messages found.
Checking for errors...
Using stronger AVC checks.
	Define empty RHTS_OPTION_STRONGER_AVC parameter if this causes any problems.
Running 'cat /mnt/testarea/tmp.rhts-db-submit-result.fb47zr | /sbin/ausearch -m AVC -m SELINUX_ERR'
Fail: AVC messages found.
Running 'cat %s | /sbin/ausearch -m USER_AVC >/mnt/testarea/tmp.rhts-db-submit-result.drqcGl 2>&1'
Info: No AVC messages found.
/bin/grep 'avc: ' /mnt/testarea/dmesg.log | /bin/grep --invert-match TESTOUT.log
No AVC messages found in dmesg
Running '/usr/sbin/sestatus'
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   enforcing
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      28
Running 'rpm -q selinux-policy || true'
selinux-policy-3.13.1-166.el7.noarch

Expected results:
Fix the AVC denials seen.

Additional info:
Comment 2 Milos Malik 2017-08-08 16:11:49 EDT
Could you enable the nis_enabled boolean and then re-run your scenario?

# setsebool -P nis_enabled on

Do you still see SELinux denials?
Comment 17 errata-xmlrpc 2018-04-10 08:36:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0763

Note You need to log in before you can comment on or make changes to this bug.