Bug 1479354 - akmods fails to compile broadcom-wl kernel module after kernel 4.10.9.200 and akmod-wl-6.30.223.271-7
akmods fails to compile broadcom-wl kernel module after kernel 4.10.9.200 and...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: akmods (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 08:16 EDT by Giuseppe Catastini
Modified: 2017-08-12 16:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-12 16:50:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Last attempt with newest kernel, same errors of previous versions. (17.46 KB, text/plain)
2017-08-08 08:16 EDT, Giuseppe Catastini
no flags Details

  None (edit)
Description Giuseppe Catastini 2017-08-08 08:16:26 EDT
Created attachment 1310600 [details]
Last attempt with newest kernel, same errors of previous versions.

Description of problem:
akmods cannot compile anymore wl.ko module 

Version-Release number of selected component (if applicable):
Fedora 25, broadcom-wl-6.30.223.271-1.fc24.noarch, akmod-wl-6.30.223.271-13.fc25.x86_64, kernel-4.11.12-200.fc25.x86_64, kernel-core-4.11.12-200.fc25.x86_64, kernel-modules-4.11.12-200.fc25.x86_64, kernel-modules-extra-4.11.12-200.fc25.x86_64, kernel-devel-4.11.12-200.fc25.x86_64, kernel-headers-4.11.12-200.fc25.x86_64

How reproducible:
Clean install of FC25 with all updates. wl.ko is not generated.

Steps to Reproduce:
1. Fresh Install of FC25 with broadcom-wl-6.30.223.271-1.fc24.noarch (from RPMfusion, applicable for FC25)
2. Update FC25 with dnf -y update
3. akmods does not generate wl.ko module
4. Try hand installation with:
sudo akmods --force --kernel `uname -r` --akmod wl

Actual results:
wl.ko module not generated

Expected results:
generated wl.ko module in /lib/modules/4.11.12-200.fc25.x86_64/extra/wl

Additional info:
lspci |grep -i broadc
09:00.0 Ethernet controller: Broadcom Limited NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
0c:00.0 Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)

last working kernel and akmods-wl: 6.30.223.271-7-for-4.10.9-200.fc25.x86_64.log

Now: 6.30.223.271-13-for-4.10.9-200.fc25.x86_64.failed.log, 6.30.223.271-13-for-4.11.12-200.fc25.x86_64.failed.log, 6.30.223.271-13-for-4.9.14-200.fc25.x86_64.failed.log
Comment 1 Giuseppe Catastini 2017-08-08 08:26:40 EDT
The error below seems to be introduced by updates/patches


2017/08/08 11:18:28 akmodsbuild: CFG80211 API is prefered for this kernel version
2017/08/08 11:18:28 akmodsbuild: Using CFG80211 API
2017/08/08 11:18:28 akmodsbuild: CC [M]  /tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64/src/shared/linux_osl.o
2017/08/08 11:18:28 akmodsbuild: /tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64/src/shared/linux_osl.c:1:0: error: code model 'kernel' not supported in the 32 bit mode
2017/08/08 11:18:28 akmodsbuild: /*
2017/08/08 11:18:28 akmodsbuild:
2017/08/08 11:18:28 akmodsbuild: /tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64/src/shared/linux_osl.c:1:0: sorry, unimplemented: 64-bit mode not compiled in
2017/08/08 11:18:28 akmodsbuild: scripts/Makefile.build:294: recipe for target '/tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64/src/shared/linux_osl.o' failed
2017/08/08 11:18:28 akmodsbuild: make[1]: *** [/tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64/src/shared/linux_osl.o] Error 1
2017/08/08 11:18:28 akmodsbuild: Makefile:1496: recipe for target '_module_/tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64' failed
2017/08/08 11:18:28 akmodsbuild: make: *** [_module_/tmp/akmodsbuild.Q6DTK16t/BUILD/wl-kmod-6.30.223.271/_kmod_build_4.11.12-200.fc25.x86_64] Error 2
2017/08/08 11:18:28 akmodsbuild: make: Leaving directory '/usr/src/kernels/4.11.12-200.fc25.x86_64'
2017/08/08 11:18:28 akmodsbuild: error: Bad exit status from /var/tmp/rpm-tmp.dpL89a (%build)
Comment 2 Richard Shaw 2017-08-08 08:33:01 EDT
99% of the time the problem is with the kmod package, not with akmods. It appears to be doing what it's supposed to do an attempting to build the kmod package. 

akmods is a utility, nothing more. You need to open the bug on RPM Fusion against the brodcom-wl-kmod package (guessing the name).
Comment 3 Nicolas Chauvet (kwizart) 2017-08-12 16:50:53 EDT
Current akmod-wl is akmod-wl-6.30.223.271-13 for f24 and later and works for kernel 4.11+.

This is not an issue with fedora or even RPM Fusion. Please use RPM Fusion repo exclusively.

Note You need to log in before you can comment on or make changes to this bug.