Bug 147938 - premature end of CD-ROM wile reading
premature end of CD-ROM wile reading
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-13 10:26 EST by Rolf Fokkens
Modified: 2015-01-04 17:16 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.12-1.1372_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-18 09:13:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rolf Fokkens 2005-02-13 10:26:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
While installing an old CD (Myth II: Soulblighter) the kernel claims:

  Feb 13 14:25:31 home01 kernel: hdd: rw=0, want=1287172, limit=1252752
  Feb 13 14:25:31 home01 kernel: Buffer I/O error on device hdd, logical block 321792
  Feb 13 14:25:31 home01 kernel: attempt to access beyond end of device

Which breaks the installation of the game. The kernel appears to assume a CD size of 1252752 blocks, while on the other hand:

  -sh-3.00# cat /proc/ide/hdd/model /proc/ide/hdd/capacity
  HL-DT-ST DVDRAM GSA-4120B
  1302360
  -sh-3.00#

The same kernel assumes a size of 1302360 blocks.

Years ago (2.4 kernel?) the CD installed w/o any problem, and even nowadays Windows is willing to read the whole CD. I think the CD itself is not the problem.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.760_FC3

How reproducible:
Always

Steps to Reproduce:
1. Load the Myth II CD
2. Do a setup
3. Notice these "attempt to access beyond end of device" messages
  

Additional info:
Comment 1 Dave Jones 2005-07-15 16:12:11 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Rolf Fokkens 2005-08-20 06:48:40 EDT
Running FC3 kernel-2.6.12-1.1372_FC3 problems are gone.

Note You need to log in before you can comment on or make changes to this bug.