Bug 1479387 - vim highlight with "background=dark" on Fedora 26 is not readable
vim highlight with "background=dark" on Fedora 26 is not readable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 09:20 EDT by AceSlash
Modified: 2017-08-17 06:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 06:09:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora 25 highlight (10.71 KB, image/png)
2017-08-08 09:20 EDT, AceSlash
no flags Details
fedora 26 highlight (10.37 KB, image/png)
2017-08-08 09:21 EDT, AceSlash
no flags Details

  None (edit)
Description AceSlash 2017-08-08 09:20:21 EDT
Created attachment 1310618 [details]
fedora 25 highlight

Description of problem:

Color scheme with background=dark is hard to read and different from the Fedora 25 version.

Version-Release number of selected component (if applicable):

vim-common-8.0.823-1.fc26.x86_64
vim-filesystem-8.0.823-1.fc26.x86_64
vim-enhanced-8.0.823-1.fc26.x86_64
vim-minimal-8.0.823-1.fc26.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Create a file with this content:
---
#!/bin/bash
this="is a test"
a=1.2.3.4
for a in {0..9}; do
        echo "$a"
done
echo "hello world"
---
2. Open it with vim
3. Type ":set background=dark"

Actual results:
The text is hard to read.

Expected results:
The text should be readable, same as it was on Fedora 25


Additional info:

I tried to switch theme, some are readable with ":colo koehler", but clearly this is a regression compared to the Fedora 25 version.

I also tried looked at the themes files in the "/usr/share/vim/vim80/colors" folder on both Fedora 25 and Fedora 26 and they are unchanged, so I guess the issue is in vim itself.
Comment 1 AceSlash 2017-08-08 09:21 EDT
Created attachment 1310619 [details]
fedora 26 highlight

Added screenshot of the difference between Fedora 25 and Fedora 26.
Comment 2 AceSlash 2017-08-08 09:22:47 EDT
May relate to https://bugzilla.redhat.com/show_bug.cgi?id=1387142
Comment 3 Elliott Forney 2017-08-11 19:17:15 EDT
This is also broken in F25 now with the following set of vim updates:

vim-common-8.0.823-1.fc25.x86_64
vim-enhanced-8.0.823-1.fc25.x86_64
vim-filesystem-8.0.823-1.fc25.x86_64
vim-minimal-8.0.823-1.fc25.x86_64
vim-X11-8.0.823-1.fc25.x86_64
Comment 4 Elliott Forney 2017-08-11 19:19:37 EDT
It looks to me like maybe vim is no longer displaying bold fonts with syntax highlighting enabled?  Even though the syntax files do not appear to have changed.
Comment 5 Elliott Forney 2017-08-11 20:08:08 EDT
Scratch that, I still have bold fonts, they are just not the same.
Comment 6 Elliott Forney 2017-08-11 20:55:47 EDT
Looks to me like a lot of the default colors and highlighting have been changed.  Not sure if this was intentional or not but it sure is hard for me to read.

In any case, the changes appear to be in the actual binary /usr/bin/vim and NOT in any of the files in /usr/share/vim.  If I copy the vim binary over from an older machine, it looks and works as expected.
Comment 7 Zdenek Dohnal 2017-08-14 06:26:07 EDT
Hi Elliot and AceSlash,

would you mind trying new VIm update in bodhi? Your problem seems similar like #1901 in VIm github https://github.com/vim/vim/issues/1901 . It should be fixed in patchlevel 831.
Comment 8 AceSlash 2017-08-16 06:09:24 EDT
Hello Zdenek,

I confirm that the latest version of F26 vim (8.0.885-1) fixes the issue.

Exact versions for reference:
vim-filesystem-8.0.885-1.fc26.x86_64
vim-enhanced-8.0.885-1.fc26.x86_64
vim-minimal-8.0.885-1.fc26.x86_64
vim-common-8.0.885-1.fc26.x86_64

Thank you!

Note You need to log in before you can comment on or make changes to this bug.