Bug 1479392 - Traffic splitting is based on # of pods and not on % per service
Traffic splitting is based on # of pods and not on % per service
Status: CLOSED DUPLICATE of bug 1470350
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Phil Cameron
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 09:31 EDT by Dan McPherson
Modified: 2017-08-08 10:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-08 10:41:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan McPherson 2017-08-08 09:31:05 EDT
Description of problem:

If I have two services and a route splitting traffic 50/50 between them, the actual split is based on how many pods there are for each service.  So if service A has 4 pods and service B has 1 pods, service A will get 4 times the traffic that service B does.



Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1. Create two services (with different home pages so you can tell the difference (Ex: 1 ruby and 1 python)).  One with 4 pods and one with 1 pod.
2. Create a route that splits traffic 50/50 between them.
3. Hit the route 10 times (from new incognito windows for each hit) and you will see that you got 8 results from 1 service and 2 from the other.

Actual results:

8 hits from 1 service and 2 from the other


Expected results:

5 hits from each service


Additional info:

This may be expected behavior from the routing tier, although I would argue it's not the desired behavior, but at a minimum this is not the expected behavior given the text in the UI/docs.
Comment 1 Dan McPherson 2017-08-08 10:12:08 EDT
Note I did this with oc cluster up.  openshift.com seems to have a little more random results.
Comment 2 Phil Cameron 2017-08-08 10:41:15 EDT
This is fixed in 1470350
PR 15309

*** This bug has been marked as a duplicate of bug 1470350 ***
Comment 3 Phil Cameron 2017-08-08 10:43:30 EDT
Also openshift-docs PR 4847

Note You need to log in before you can comment on or make changes to this bug.