Bug 1479408 - Overall stability of wayland GNOME session is way worse than GNOME X11 session because WM crashes take down the etnire session
Overall stability of wayland GNOME session is way worse than GNOME X11 sessio...
Status: CLOSED DUPLICATE of bug 1367666
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
27
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 10:14 EDT by Jonas Thiem
Modified: 2017-11-03 15:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-03 15:34:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2017-08-08 10:14:22 EDT
Description of problem:
Overall stability of wayland GNOME session is way worse than GNOME X11 session because WM crashes always seem take down the etnire session.

Since this impacts my ability to do work productively (and I imagine for other people as well), I suggest the current marriage of wayland compositor & the whole WM logic, activities overview UI and all the other behavioral things in one process should be reconsidered for GNOME 3 specifically for the sake of better stability.

Version-Release number of selected component (if applicable):
3.24.2 (but basically any version back to when the GNOME Wayland session was introduced)

How reproducible:
Sporadical crashes ranging from monthly to more than weekly, varying wildly depending on the exact GNOME version and setup

Steps to Reproduce:
1. Use GNOME Wayland session

Actual results:
When GNOME crashes it brings down the entire session with all the windows and I lose progress. Sadly, this happens often enough to be quite a nuisance

Expected results:
Similar to the X11 session, as much as possible is separated from the compositor / display manager part so that there is a possibility of a crash not bringing down the entire session.

Additional info:
Comment 1 Matthew Miller 2017-11-03 15:34:55 EDT

*** This bug has been marked as a duplicate of bug 1367666 ***

Note You need to log in before you can comment on or make changes to this bug.