Bug 1479415 - bzr-fastimport: Missing build-time dependency on python2-devel
bzr-fastimport: Missing build-time dependency on python2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bzr-fastimport (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 10:23 EDT by Iryna Shcherbina
Modified: 2017-08-14 02:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: bzr-fastimport-0.13.0-11.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 02:39:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Adds a missing build-time dependency on python2-devel (2.01 KB, application/mbox)
2017-08-08 10:23 EDT, Iryna Shcherbina
no flags Details

  None (edit)
Description Iryna Shcherbina 2017-08-08 10:23:47 EDT
Created attachment 1310633 [details]
Adds a missing build-time dependency on python2-devel

The bzr-fastimport RPM is missing the build-time dependency on python2-devel.

This is the reason why the dependency on Python itself is not generated for bzr-fastimport-0.13.0-10.fc27:

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --requires bzr-fastimport
bzr
python-fastimport

According to Fedora Packaging Guidelines for Python [0], packages building for Python 2 need BuildRequires: python2-devel.

I have attached the patch which adds a missing build-time dependency and modernizes the spec file. Please review it and apply.

[0] https://fedoraproject.org/wiki/Packaging:Python#Dependencies
Comment 1 Dan Callaghan 2017-08-14 02:39:58 EDT
Thanks! Applied.

Note You need to log in before you can comment on or make changes to this bug.