Bug 1479452 - Exposing routes based on a sharded router using NAMESPACE_LABELS takes too long.
Exposing routes based on a sharded router using NAMESPACE_LABELS takes too long.
Status: CLOSED DUPLICATE of bug 1479295
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ben Bennett
zhaozhanqi
aos-scalability-36
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 10:58 EDT by jmencak
Modified: 2017-08-09 14:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 14:20:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmencak 2017-08-08 10:58:06 EDT
Description of problem:
Sharded routers based on project namespace labels take too long to register a route.  It can take around 7 minutes for the router to register a newly exposed route within a namespace.

Version-Release number of selected component (if applicable):
v3.6.131 

How reproducible:
Always.


Steps to Reproduce:
https://asciinema.org/a/sMCJJ6ThrthFpQdVADG6Gy5YK

Actual results:
Routes take too long to register based on NAMESPACE_LABELS.

Expected results:
Near "immediate" registration of an exposed route on a NAMESPACE_LABELS-sharded router, just as it happens when using ROUTE_LABELS.

Additional info:
You can fast forward to end of the recording to see how long it can take for a route to become exposed.
Comment 1 Rajat Chopra 2017-08-08 13:59:03 EDT
Can you confirm that it is only when route is created on a newly created project?
On an existing project (one that has synced in ~10 minutes) the routes appear as quickly as in a non-sharded router. If yes, this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1355711
Comment 2 jmencak 2017-08-09 04:56:25 EDT
(In reply to Rajat Chopra from comment #1)
> Can you confirm that it is only when route is created on a newly created
> project?
Yes, this is correct.  Also, if I wait for the routes to be exposed correctly (those max ~10 minutes), I delete the project and re-create the project under the same name, the routes are exposed correctly immediately.  So this only seems to affect completely new namespaces for which routes have not been resynced with the router.  So, yes a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1355711.
Comment 3 Phil Cameron 2017-08-09 11:18:33 EDT
Also duplicate of: https://bugzilla.redhat.com/show_bug.cgi?id=1479295
Comment 4 Rajat Chopra 2017-08-09 14:20:41 EDT

*** This bug has been marked as a duplicate of bug 1479295 ***

Note You need to log in before you can comment on or make changes to this bug.