Bug 1479480 - Add google-compute-engine and python-google-compute-engine builds to RHGS
Add google-compute-engine and python-google-compute-engine builds to RHGS
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
3.3
Unspecified Unspecified
high Severity high
: Release Candidate
: ---
Assigned To: Sreenath G
Bala Konda Reddy M
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-08-08 11:42 EDT by Sreenath G
Modified: 2017-09-27 08:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: google-compute-engine-init-2.1.2-1.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-27 08:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sreenath G 2017-08-08 11:42:08 EDT
Description of problem:
Need to create google-compute-engine package which gives the below sub-pkgs (RPMs) which need to be included in RHGS Qcow2 images for GCE.


*google-compute-engine* is a Python package for Linux daemons, scripts, and libraries.
       The package is installed to its distro default Python package location (e.g. /usr/lib/python2.7/site-packages).
    Entry point scripts, created by the Python package, are located in /usr/bin.

*google-compute-engine-init* is a package that contains init configuration for the google-compute-engine Python package. Installing this package will configure the google-compute-engine package to run on system startup on sysvinit, upstart, or systemd init systems.

*google-config* is a package containing non-Python scripts and guest configuration.

    Sets up udev rules and sysctl rules.
    Configures the SysLog output that gets sent to serial port output.
    Includes bash scripts needed by instance_setup


Upstream source : github.com/GoogleCloudPlatform/compute-image-packages.git

Version-Release number of selected component (if applicable):
Comment 3 Rejy M Cyriac 2017-09-18 07:22:11 EDT
Revised set of net new builds to be added to RHGS

google-compute-engine

python-google-compute-engine
Comment 9 errata-xmlrpc 2017-09-27 08:20:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2812

Note You need to log in before you can comment on or make changes to this bug.