Bug 1479539 - Missing python-kubernetes dependency at runtime
Missing python-kubernetes dependency at runtime
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-rally (Show other bugs)
12.0 (Pike)
x86_64 Linux
medium Severity medium
: beta
: 12.0 (Pike)
Assigned To: Chandan Kumar
Martin Kopec
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 14:35 EDT by Dimitri Savineau
Modified: 2017-12-13 16:49 EST (History)
5 users (show)

See Also:
Fixed In Version: openstack-rally-0.9.1-0.20170805004733.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:49:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
RDO 7914 None None None 2017-08-10 10:07 EDT

  None (edit)
Description Dimitri Savineau 2017-08-08 14:35:54 EDT
Description of problem:
Using rally deployment create command will result a python trace due to the missing kubernetes module.

Version-Release number of selected component (if applicable):
RHEL 7.4 with RHOS-12.0 2017-08-08.4
openstack-rally-0.9.1-0.20170805004732.0aa2f58.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install openstack-rally package
2. Run rally-manage db create && rally deployment create --fromenv --name=existing

Actual results:

$ rally deployment create --fromenv --name=existing
Command failed, please check log for more info
2017-08-08 14:27:45.686 25821 CRITICAL rally [-] Unhandled error: ImportError: No module named kubernetes
2017-08-08 14:27:45.686 25821 ERROR rally Traceback (most recent call last):
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/bin/rally", line 10, in <module>
2017-08-08 14:27:45.686 25821 ERROR rally     sys.exit(main())
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/cli/main.py", line 38, in main
2017-08-08 14:27:45.686 25821 ERROR rally     return cliutils.run(sys.argv, categories)
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/cli/cliutils.py", line 660, in run
2017-08-08 14:27:45.686 25821 ERROR rally     ret = fn(*fn_args, **fn_kwargs)
2017-08-08 14:27:45.686 25821 ERROR rally   File "<string>", line 2, in create
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/plugins/__init__.py", line 50, in ensure_plugins_are_loaded
2017-08-08 14:27:45.686 25821 ERROR rally     load()
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/plugins/__init__.py", line 37, in load
2017-08-08 14:27:45.686 25821 ERROR rally     discover.import_modules_from_package("rally.plugins.openstack")
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/common/plugin/discover.py", line 68, in import_modules_from_package
2017-08-08 14:27:45.686 25821 ERROR rally     module_name)
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/oslo_utils/importutils.py", line 73, in import_module
2017-08-08 14:27:45.686 25821 ERROR rally     __import__(import_str)
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/plugins/openstack/context/magnum/ca_certs.py", line 29, in <module>
2017-08-08 14:27:45.686 25821 ERROR rally     from rally.plugins.openstack.scenarios.magnum import utils as magnum_utils
2017-08-08 14:27:45.686 25821 ERROR rally   File "/usr/lib/python2.7/site-packages/rally/plugins/openstack/scenarios/magnum/utils.py", line 22, in <module>
2017-08-08 14:27:45.686 25821 ERROR rally     from kubernetes import client as k8s_config
2017-08-08 14:27:45.686 25821 ERROR rally ImportError: No module named kubernetes
2017-08-08 14:27:45.686 25821 ERROR rally

Expected results:
$ rally deployment create --fromenv --name=existing
2017-08-08 14:31:11.510 25989 INFO rally.deployment.engines.existing [-] Save deployment 'existing' (uuid=5dab3e76-717c-4ac1-98bd-464530641cce) with 'openstack' platform.
+--------------------------------------+---------------------+----------+------------------+--------+
| uuid                                 | created_at          | name     | status           | active |
+--------------------------------------+---------------------+----------+------------------+--------+
| 5dab3e76-717c-4ac1-98bd-464530641cce | 2017-08-08T18:31:11 | existing | deploy->finished |        |
+--------------------------------------+---------------------+----------+------------------+--------+
Using deployment: 5dab3e76-717c-4ac1-98bd-464530641cce
~/.rally/openrc was updated

HINTS:

* To use standard OpenStack clients, set up your env by running:
        source ~/.rally/openrc
  OpenStack clients are now configured, e.g run:
        openstack image list

Additional info:
Upstream RDO added python-kubernetes as a dependency to rally package [1] and turned it optional for OSP because the package doesn't exist. But kubernetes is still a runtime library for magnum tests.

[1] https://review.rdoproject.org/r/#/c/6726
[2] https://review.rdoproject.org/r/#/c/7528
Comment 1 Chandan Kumar 2017-08-10 10:08:00 EDT
Fixed in https://review.rdoproject.org/r/#/c/7914/
Comment 2 Red Hat Bugzilla Rules Engine 2017-08-10 10:16:49 EDT
This bugzilla has been removed from the release since it has not been triaged, and needs to be reviewed for targeting another release.
Comment 3 Jon Schlueter 2017-08-10 11:28:31 EDT
pulled merged RDO packaging into downstream.
Comment 6 Martin Kopec 2017-08-16 16:52:49 EDT
The issue is fixed in the openstack-rally-0.9.1-0.20170805004733.el7ost package -> verified.
Comment 9 errata-xmlrpc 2017-12-13 16:49:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.