Bug 147957 - DBD-Pg core dumps when doing a select from a variable length array
Summary: DBD-Pg core dumps when doing a select from a variable length array
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-DBD-Pg   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-14 01:33 UTC by Dan Vietor
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 16:22:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Vietor 2005-02-14 01:33:51 UTC
Description of problem:
PostgreSQL module for Perl core dumps whenever you access a variable
length array.  

Version-Release number of selected component (if applicable):
1.31

How reproducible:
Core dumps every time with every select function

Steps to Reproduce:
1. Create a variable length array in postgres
2. Submit any select command to retrieve a value from that array
3. Immediate core dump
  
Actual results:


Expected results:


Additional info:
Variable length arrays are pretty new to PostgreSQL.  I had to update
the DBD-Pg module to 1.32 to eliminate the core dumps.  In addition, I
had to remove the 1.31 package since the CPAN install of the 1.32
module is lower on the search path than the one installed with FC3.  

So 1.32 works fine with variable length arrays... 1.31 does not.

Comment 1 Florian La Roche 2005-11-03 16:22:20 UTC
Ok, this should at least be fixed now in the FC-development tree.

Thanks,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.