Bug 1479623 - Scroll wheel of virtio-mouse doesn't work for rhel7.4 guest
Summary: Scroll wheel of virtio-mouse doesn't work for rhel7.4 guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Guo, Zhiyi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-09 01:49 UTC by Guo, Zhiyi
Modified: 2018-11-01 11:01 UTC (History)
10 users (show)

Fixed In Version: qemu-kvm-rhev-2.12.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-01 11:01:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Guo, Zhiyi 2017-08-09 01:49:23 UTC
Description of problem:
Scroll wheel of virtio-mouse doesn't work for rhel7.4 guest

Version-Release number of selected component (if applicable):
3.10.0-693.el7.x86_64(host & guest)
qemu-kvm-rhev-2.9.0-16.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Boot a guest with virtio-mouse using qemu cli:
/usr/libexec/qemu-kvm -name virtio-vga -m 2G -machine pc,accel=kvm,vmport=off \
        -cpu Skylake-Client\
        -smp 1 \
        -serial unix:/tmp/console1,server,nowait \
        -monitor stdio \
        -device VGA,id=vga1 \
        -drive file=rhelsp4.qcow2,if=none,id=drive-scsi-disk0,format=qcow2,cache=none,werror=stop,rerror=stop
 -device virtio-scsi-pci,id=scsi0,addr=04 -device scsi-hd,drive=drive-scsi-disk0,bus=scsi0.0,scsi-id=0,lun=0,
id=scsi-disk0,bootindex=1 \
        -netdev tap,id=idinWyYp,vhost=on -device virtio-net-pci,mac=42:ce:a9:d2:4d:d8,id=idlbq7eA,netdev=idin
WyYp \
        -vnc :0  \
        -device ich9-usb-uhci6 \
        -device virtio-keyboard-pci,id=kbd-bus  -device virtio-mouse-pci,id=mouse-bus  \

2.In guest, test virtio-mouse with xinput. In my case, I list input devices by:
#xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ QEMU Virtio Mouse                         id=8    [slave  pointer  (2)]
⎜   ↳ ImExPS/2 Generic Explorer Mouse           id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ QEMU Virtio Keyboard                      id=7    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=9    [slave  keyboard (3)]

And test virtio mouse by:
#xinput test 8
xinput will print the events recevied from virtio mouse, then scroll the scroll wheel of mouse
3.

Actual results:
Nothing prompt after scrolling the scroll wheel of mouse

Expected results:
Events of scroll wheel should be prompted 

Additional info:
1) Both vnc and spice has this issue.
2) Test against ps2/vmmouse/usb-kbd/spice vdagent tablet, all of them can generate scroll events during test.
3) No such issue happen in windows 10 guest with virtio-win driver virtio-win-1.9.3.iso, scroll wheel works correctly.
4) Test against upstream stable qemu2.6.2, also has this issue, so this is not a regression of qemu-kvm-rhev.

Comment 2 Xujun Ma 2017-08-10 00:26:31 UTC
The same issue on the ppc platform.

Comment 3 Marc-Andre Lureau 2017-08-10 13:14:42 UTC
possible fix:
http://patchew.org/QEMU/20170808224750.23904-1-marcandre.lureau@redhat.com/

Comment 4 Marc-Andre Lureau 2017-10-06 11:31:08 UTC
Fixed in commit f4924974c7c72560f68ab298ac25a525a28a2124

Comment 5 Guo, Zhiyi 2017-11-13 06:05:39 UTC
Test against rhel 7.5 host & guest with kernel 3.10.0-768.el7.x86_64 and qemu-kvm-rhev-2.10.0-5.el7.x86_64,

wheel buttons are missing for both virtio-mouse-pci and virtio-tablet-pci.

Comment 6 Marc-Andre Lureau 2017-11-16 11:13:53 UTC
(In reply to Guo, Zhiyi from comment #5)
> Test against rhel 7.5 host & guest with kernel 3.10.0-768.el7.x86_64 and
> qemu-kvm-rhev-2.10.0-5.el7.x86_64,
> 
> wheel buttons are missing for both virtio-mouse-pci and virtio-tablet-pci.

The fixed will be in 2.11, and will require wheel-axis=true with machine < 2.11. I don't know if it's worth to backport. Should we move it to 7.6? Gerd, what do you think?

Comment 7 Gerd Hoffmann 2017-11-17 06:14:29 UTC
> The fixed will be in 2.11, and will require wheel-axis=true with machine <
> 2.11. I don't know if it's worth to backport. Should we move it to 7.6?
> Gerd, what do you think?

Defer to 7.6 is fine I think.

Comment 8 Marc-Andre Lureau 2018-04-16 13:23:32 UTC
Fixed in commit f4924974c7c72560f68ab298ac25a525a28a2124 upstream

Comment 14 errata-xmlrpc 2018-11-01 11:01:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3443


Note You need to log in before you can comment on or make changes to this bug.