Bug 1479625 - caja: mate-file-manager* virtual provides removed in updates repo
caja: mate-file-manager* virtual provides removed in updates repo
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: caja (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-08 22:16 EDT by Mihai Moldovan
Modified: 2017-08-28 18:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: caja-1.18.4-1.fc26 caja-1.18.4-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-28 12:20:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mock build log with package build-depending upon mate-file-manager-devel. (99.81 KB, text/plain)
2017-08-09 02:55 EDT, Mihai Moldovan
no flags Details

  None (edit)
Description Mihai Moldovan 2017-08-08 22:16:00 EDT
https://src.fedoraproject.org/rpms/caja/c/d482b74182257b86b07dd23cc66e2eddc3747298 removed the mate-file-manager* virtual provides and was pushed to the f25 branch.

Since then, we have:
  - caja 1.16.x in the os repository WITH the provides
  - caja 1.18.x in the updates repository WITHOUT the provides

Any software depending upon the virtual mate-file-manager* provides will likely fail, since they will pull in caja 1.16.x. If any other package pulls in caja 1.18.x via dependencies, we get a nice set of conflicts.

Please re-add the virtual provides to the updates-repo package.
Comment 1 Mihai Moldovan 2017-08-08 22:22:09 EDT
This problem also affects fc26: https://src.fedoraproject.org/rpms/caja/c/704d162af25e4011be565078a97da1b77ca28ae4
Comment 2 Wolfgang Ulbrich 2017-08-09 02:46:43 EDT
Can you please provide an dnf log.
The provides was added in f20 for renaming mate-filemanager to caja, for updating mate-file-manager package with caja.

After 5 releases it should be save to remove the provides, but maybe i did that to early.

And which 1.16. x version you want to update?
Because other people didn't run in this problem with updating MATE-1.16 to 1.18 in f25.
Comment 3 Mihai Moldovan 2017-08-09 02:55 EDT
Created attachment 1311021 [details]
mock build log with package build-depending upon mate-file-manager-devel.

It's fine to rename the package and the virtual packages certainly help, but please don't change that for already released versions. That change is totally fine in rawhide - and there's nothing wrong with only having caja-* in FC27+.

Will attach a yum log (dnf is impossible to test for me currently, since I build packages on a Debian machine via mock and dnf hasn't been backported yet.)

The problem is certainly aggravated by wrong build dependencies: my package is still depending upon mate-file-manager-devel. I should change that to caja-devel.
Comment 4 Wolfgang Ulbrich 2017-08-09 03:14:24 EDT
Hmmm, I will try to reproduce this with updating a fresh f25 VM installed from MATE-Compiz spin with caja-1.16 to current 1.18 version.
But using mate-file-manger-devel as build requires is wrong.
Please take a look at fedora spec files for correct build requires.
https://src.fedoraproject.org/rpms/caja/tree
Comment 5 Mihai Moldovan 2017-08-09 03:22:30 EDT
You won't be able to reproduce this problem with a normal upgrade.

The issue is triggered by my package (x2gomatebindings) build-depending upon mate-file-manager-devel.


Doing something like:
  - install base FC25 VM (with updates repo enabled, which is the default anyway)
  - install MATE
  - explicitly try to install mate-file-manager-devel

should trigger that problem as well, though.


I agree that I should switch to build-depending on caja-devel instead of mate-file-manager-devel. Will do that.

Still, building with the legacy mate-file-manager-devel build dependency on FC25 and FC26 worked before the new caja-devel version reached the updates repo.
Comment 6 Wolfgang Ulbrich 2017-08-09 03:35:45 EDT
I see only x2goserver-fmbindings in repo.
I will try to reproduce the issue if this package is installed.
Comment 7 Mihai Moldovan 2017-08-09 03:41:36 EDT
It's an upstream package not part of Fedora IIRC. :) Orion has only ported the most common components, *bindings aren't AFAIK.

Build dependency fixed upstream: https://code.x2go.org/gitweb?p=x2gomatebindings.git;a=commitdiff;h=700eec0b511210c973d8cc6023dae16392c7a177;hp=3802d40e5749ba9b7fd705aa093ceab467211972

With that, the package should build fine in an FC25 and FC26 environment again. It doesn't make the bug report obsolete, though, since any other software build-depending upon mate-file-manager-devel can run into this problem.
Comment 8 Wolfgang Ulbrich 2017-08-09 04:08:41 EDT
But which package use wrong build requires in fedora repos?
I don't see any.

[root@f25-test rave]# dnf repoquery --whatrequires caja
Letzte Prüfung auf abgelaufene Metadaten: vor 0:24:33 am Wed Aug  9 09:29:50 2017.
atril-caja-0:1.16.0-1.fc25.x86_64
atril-caja-0:1.18.0-1.fc25.x86_64
atril-thumbnailer-0:1.16.0-1.fc25.x86_64
atril-thumbnailer-0:1.18.0-1.fc25.x86_64
caja-beesu-manager-0:1.8-27.fc24.noarch
nextcloud-client-caja-0:2.3.2-1.fc25.x86_64
owncloud-client-caja-0:2.3.2-1.fc25.x86_64
rabbitvcs-caja-0:0.16.1-0.5.20160108gite8214e6.fc25.noarch

[root@f25-test rave]# dnf repoquery --whatrequires mate-file-manager
Letzte Prüfung auf abgelaufene Metadaten: vor 0:24:45 am Wed Aug  9 09:29:50 2017.
[root@f25-test rave]# 

In MATE upstream we renamed the package 3 years ago, enough time for all **third-party packages** to change their build requires.
Comment 9 Wolfgang Ulbrich 2017-08-09 04:13:26 EDT
As expected in f25 VM:

[root@f25-test rave]# dnf update
Last metadata expiration check: 0:41:44 ago on Wed Aug  9 09:29:50 2017.
Dependencies resolved.

<cut>

 xorg-x11-server-Xorg            x86_64 1.19.3-1.fc25             updates 1.5 M
 xorg-x11-server-common          x86_64 1.19.3-1.fc25             updates  48 k
 xorg-x11-xinit                  x86_64 1.3.4-13.fc25             updates  55 k

Transaction Summary
================================================================================
Install   21 Packages
Upgrade  712 Packages

Total download size: 892 M
Is this ok [y/N]:
Comment 10 Mihai Moldovan 2017-08-09 04:21:42 EDT
I'm late to the party, yep. Definitely my fault.

It's also relieving to know that no package within FC25 seems to actually be build-depending upon mate-file-manager-devel.

But with all that acknowledged, isn't it a regression that mate-file-manager-(devel) could be selected before the caja upgrade in the updates repo and now can't?


It's certainly nothing high-priority.


----


<snip>
As expected in f25 VM:
</snip>

This does have MATE (including caja) installed, right? Yeah, that'll perfectly work for upgrades.


If you excute "dnf install mate-file-manager", that should fail with an error now.
Comment 11 Wolfgang Ulbrich 2017-08-09 04:54:14 EDT
Well,
it's a theoretical issue, but those outputs are worse :-)

[root@f25-test rave]# dnf install mate-file-manager
Last metadata expiration check: 1:05:55 ago on Wed Aug  9 09:29:50 2017.
Error: cannot install both caja-1.16.1-1.fc25.x86_64 and caja-1.18.3-3.fc25.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)

For f26 it becomes funny :-)

[root@f26 rave]# dnf -v install mate-file-manager

<cut>

Last metadata expiration check: 0:01:49 ago on Wed 09 Aug 2017 10:47:03 AM CEST.
--> Starting dependency resolution
---> Package caja.x86_64 1.18.3-1.fc26 will be a downgrade
---> Package caja-extensions.x86_64 1.18.3-1.fc26 will be a downgrade
---> Package caja-schemas.x86_64 1.18.3-1.fc26 will be a downgrade
--> Finished dependency resolution
Dependencies resolved.
================================================================================
 Package                Arch          Version               Repository     Size
================================================================================
Downgrading:
 caja                   x86_64        1.18.3-1.fc26         fedora        1.4 M
 caja-extensions        x86_64        1.18.3-1.fc26         fedora         36 k
 caja-schemas           x86_64        1.18.3-1.fc26         fedora        2.1 M

Transaction Summary
================================================================================
Downgrade  3 Packages

Total download size: 3.5 M
Is this ok [y/N]:

dnf install >> dnf downgrade


Ok, i will add the virtual provides again with next needed build.
Comment 12 Björn 'besser82' Esser 2017-08-09 07:19:52 EDT
(In reply to Wolfgang Ulbrich from comment #11)
> Ok, i will add the virtual provides again with next needed build.

The build is needed just to resolve this issue, since the upgrade path for a (virtual) package within the same Fedora release is broken, now.
Comment 13 Fedora Update System 2017-08-26 10:10:31 EDT
caja-1.18.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ebe2c063ab
Comment 14 Fedora Update System 2017-08-26 10:10:40 EDT
caja-1.18.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-155e945695
Comment 15 Fedora Update System 2017-08-26 18:37:15 EDT
caja-1.18.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ebe2c063ab
Comment 16 Fedora Update System 2017-08-26 18:38:13 EDT
caja-1.18.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-155e945695
Comment 17 Fedora Update System 2017-08-28 12:20:16 EDT
caja-1.18.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2017-08-28 18:22:28 EDT
caja-1.18.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.