Bug 1479657 - update is dragging in fuse and fuse-zfs as dependencies
Summary: update is dragging in fuse and fuse-zfs as dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-09 05:01 UTC by Chris Murphy
Modified: 2017-08-24 23:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-09 10:47:50 UTC
Type: Bug


Attachments (Terms of Use)
debugdata from debugsolver (9.18 MB, application/x-tar)
2017-08-09 05:01 UTC, Chris Murphy
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1471912 0 unspecified CLOSED Enable ZFS storage driver in libvirt (patch sent to libvirt ML) 2021-02-22 00:41:40 UTC

Internal Links: 1471912

Description Chris Murphy 2017-08-09 05:01:17 UTC
Created attachment 1310998 [details]
debugdata from debugsolver

Description of problem:

Several packages are being dragged in as dependencies for unknown reasons during a normal 'dnf update' including ZFS stuff. Fedora doesn't support ZFS at all so this seems weird.


Version-Release number of selected component (if applicable):
dnf-2.6.2-1.fc26.noarch

How reproducible:
Always, but just today. Last week's updates didn't do this, or at any time prior.

Steps to Reproduce:
1. dnf update
2.
3.

Actual results:

Installing dependencies:
 fuse                                                         x86_64                       2.9.7-2.fc26                          fedora                                 83 k
 libvirt-daemon-driver-storage-zfs                            x86_64                       3.2.1-5.fc26                          updates-testing                        18 k
 python2-asn1crypto                                           noarch                       0.22.0-4.fc26                         updates                               173 k
 python2-jwcrypto                                             noarch                       0.4.2-3.fc26                          updates-testing                        62 k
     replacing  python-jwcrypto.noarch 0.3.2-3.fc26
 python3-asn1crypto                                           noarch                       0.22.0-4.fc26                         updates                               176 k
 zfs-fuse 


Expected results:

Honestly I don't know. Maybe that I should get some reference to what update is causing these uninstalled dependencies to need to be installed, which is more of a feature request than a bug. But I'm definitely not expecting fuse, zfs-fuse, or the libvirt zfs driver to be installed since I have nothing ZFS related on this system.


Additional info:

Comment 1 Chris Murphy 2017-08-09 05:11:05 UTC
[chris@f26s ~]$ sudo dnf update --exclude=zfs-fuse

Skipping packages with broken dependencies:
cockpit-machines
libvirt
libvirt-daemon-kvm


[chris@f26s ~]$ sudo dnf update libvirt

Installing dependencies:
fuse
libvirt-daemon-driver-storage-zfs 
zfs-fuse  

Doesn't happen if I just update cockpit or cockpit-machines. So for whatever reason libvirt 3.2.1-5.fc26 update is trying to drag in ZFS stuff.

Comment 2 Chris Murphy 2017-08-09 05:13:32 UTC
Nevermind, looks intentional. Bug 1471912.

Comment 3 Chris Murphy 2017-08-09 06:21:07 UTC
On third thought, "get some reference to what update is causing these uninstalled dependencies to need to be installed" still seems like a valid feature request.

Comment 4 Igor Gnatenko 2017-08-09 10:47:50 UTC
T(In reply to Chris Murphy from comment #3)
> On third thought, "get some reference to what update is causing these
> uninstalled dependencies to need to be installed" still seems like a valid
> feature request.

This has been requested in some other bug which I can't find right now.

Comment 5 Cole Robinson 2017-08-09 13:30:45 UTC
just a note, the 'libvirt' package is a metapackage that pulls in every libvirt subpackage. you can remove it, and only install the libvirt-daemon-storage-driver-X bits that you need, which for most users is likely just libvirt-daemon-storage-driver-core

Comment 6 Lars Nielsen 2017-08-24 18:58:02 UTC
Really surprised to see this closed as NOTABUG :(

Comment 7 Cole Robinson 2017-08-24 20:29:48 UTC
Lars, see comment #5 for a workaround. Maybe you are installing the bare libvirt package but that's overkill

Comment 8 Lars Nielsen 2017-08-24 23:21:01 UTC
I realize there is a workaround. I just feel that it is wrong for the package which a lot of people will probably install, to pull in a lot of unnecessary packages.


Note You need to log in before you can comment on or make changes to this bug.