Bug 1479672 - collectd.cpu.percent is transformed to collectd.CPU.percent
Summary: collectd.cpu.percent is transformed to collectd.CPU.percent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.7.0
Assignee: Jan Wozniak
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-09 06:40 UTC by Shirly Radco
Modified: 2017-12-18 13:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-18 13:22:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 659 None None None 2017-09-13 18:27:44 UTC
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Shirly Radco 2017-08-09 06:40:32 UTC
Description of problem:
For some reason the collectd.cpu.percent field is transformed to collectd.CPU.percent.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Field name is collectd.CPU.percent.

Expected results:
Field name should be collectd.cpu.percent

Additional info:

Comment 1 Jan Wozniak 2017-09-05 13:55:25 UTC
Could you please provide more information and why do you expect small case 'cpu'? Is it possible it is desired to have 'CPU' in capital letters? Because it looks like the field is expected to be 'CPU' based on these references: index pattern [1], elasticsearch index templates [2], convention of how CPU plugin for collectd is named [3]


[1] https://github.com/openshift/origin-aggregated-logging/blob/master/elasticsearch/index_patterns/com.redhat.viaq-openshift.index-pattern.json

[2] https://github.com/wozniakjan/elasticsearch-templates/blob/master/namespaces/collectd.yml

[3] https://collectd.org/wiki/index.php/Plugin:CPU

Comment 2 Shirly Radco 2017-09-11 06:48:51 UTC
There was a mistake in the elasticsearch-templates namespace.
Fixed the issue in https://github.com/ViaQ/elasticsearch-templates/commit/4e952bd9f4a500321d68da8abf5a9211c632a3d3

Comment 3 Rich Megginson 2017-11-21 18:11:53 UTC
3.7 - fix is in version 3.7.7 or later

3.6 - fix is in v3.6.173.0.65 or later

Comment 4 Anping Li 2017-11-22 09:03:02 UTC
@Lukas, I guess this bug is in RHV too.  Help us verify it. Thanks

Comment 5 Wei Sun 2017-11-29 02:34:21 UTC
Hi Lukas,
Could you help check if this bug could be verified?

Thanks!

Comment 6 Lukas Svaty 2017-11-29 10:27:29 UTC
verified in openshift-ansible-3.6.173.0.75-1.git.0.0a44128.el7.noarch

Comment 9 errata-xmlrpc 2017-12-18 13:22:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.