Bug 1479677 - [RFE] - LLDP protocol REST API support
[RFE] - LLDP protocol REST API support
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
---
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.1.6
: 4.1.6.1
Assigned To: Dominik Holler
Michael Burman
: FutureFeature
Depends On: 1477205
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 03:29 EDT by Dominik Holler
Modified: 2017-09-20 00:46 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This update adds support for Link Layer Discovery Protocol (LLDP) in Red Hat Virtualization. To support the integration of Red Hat Virtualization with other software, the information gathered by LLDP on each host will be provided by the Manager's REST API. Information such as the switch port number the host's network interface is connected to, will be shown in the GUI. Known Issue BZ#1487930: Cisco switches might send VLAN tagged 802.1Q LLDP frames. These LLDP frames are ignored if the NIC of the Red Hat Virtualization host is not attached to the corresponding Red Hat Virtualization logical network.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-19 06:01:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
mburman: testing_plan_complete+
ylavi: planning_ack+
rule-engine: devel_ack+
mburman: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78580 master MERGED restapi: Add LLDP 2017-08-28 08:23 EDT
oVirt gerrit 80186 ovirt-4.1 MERGED network: add driverloader module 2017-08-22 17:31 EDT
oVirt gerrit 80187 ovirt-4.1 MERGED net: Introduce the LLDPAD driver with an LLDP interface 2017-08-22 17:31 EDT
oVirt gerrit 80192 ovirt-4.1 MERGED net: Enable LLDP on NICs 2017-08-22 17:31 EDT
oVirt gerrit 80193 ovirt-4.1 MERGED net: Add info lldp to lldp 2017-08-22 17:31 EDT
oVirt gerrit 80194 ovirt-4.1 MERGED net: Report lldp through new getLldp command 2017-08-22 17:31 EDT
oVirt gerrit 80327 ovirt-4.1 MERGED net: Introduce network initializer module 2017-08-22 17:31 EDT
oVirt gerrit 80390 ovirt-4.1 MERGED net: Report empty LLDP TLV lists for operationally-down interfaces 2017-08-22 17:31 EDT
oVirt gerrit 80506 ovirt-engine-4.1 MERGED net: Add entities for LLDP 2017-08-29 07:58 EDT
oVirt gerrit 80509 ovirt-engine-4.1 MERGED core: Add GetTlvsByHostNicIdQuery 2017-08-29 07:58 EDT
oVirt gerrit 80511 ovirt-engine-4.1 MERGED restapi: Add LLDP 2017-08-29 07:58 EDT
oVirt gerrit 81119 ovirt-engine-4.1 MERGED restapi: Update to model 4.1.39 2017-08-28 12:52 EDT
Github https://github.com/oVirt/ovirt-site/pull/1174 None None None 2017-08-28 10:26 EDT

  None (edit)
Description Dominik Holler 2017-08-09 03:29:58 EDT
Description of problem:

oVirt should provide Link Layer Discovery Protocol (LLDP) Support.
oVirt hosts should gather information from their networking interfaces and let oVirt Engine provide this information on REST-API, like described in https://github.com/oVirt/ovirt-site/pull/1027

Actual results:

No LLDP information in oVirt REST-API available

Expected results:

LLDP information in oVirt REST-API available
Comment 2 Meni Yakove 2017-08-28 04:53:09 EDT
REST is not merged for 4.1

<host_nichref="/ovirt-engine/api/hosts/9d1d577b-a482-42ef-82c7-7d74169958fa/nics/eae47b64-a78a-4476-a74d-8f29b9ec7d62"id="eae47b64-a78a-4476-a74d-8f29b9ec7d62">
<actions/>
<name>enp2s0f0</name>
<linkhref="/ovirt-engine/api/hosts/9d1d577b-a482-42ef-82c7-7d74169958fa/nics/eae47b64-a78a-4476-a74d-8f29b9ec7d62/networklabels"rel="networklabels"/>
<linkhref="/ovirt-engine/api/hosts/9d1d577b-a482-42ef-82c7-7d74169958fa/nics/eae47b64-a78a-4476-a74d-8f29b9ec7d62/networkattachments"rel="networkattachments"/>
<linkhref="/ovirt-engine/api/hosts/9d1d577b-a482-42ef-82c7-7d74169958fa/nics/eae47b64-a78a-4476-a74d-8f29b9ec7d62/statistics"rel="statistics"/>
<boot_protocol>none</boot_protocol>
<bridged>false</bridged>
<ip>
<address/>
<netmask/>
<version>v4</version>
</ip>
<ipv6_boot_protocol>none</ipv6_boot_protocol>
<mac>
<address>00:e0:ed:33:c0:96</address>
</mac>
<mtu>1500</mtu>
<speed>1000000000</speed>
<status>up</status>
<hosthref="/ovirt-engine/api/hosts/9d1d577b-a482-42ef-82c7-7d74169958fa"id="9d1d577b-a482-42ef-82c7-7d74169958fa"/>
</host_nic>


No linklayerdiscoveryprotocolelements


Also the feature page says that in the REST the name is linklayerdiscoveryprotocolinformationelements but in REST it's linklayerdiscoveryprotocolelements
Comment 3 Red Hat Bugzilla Rules Engine 2017-08-28 12:40:02 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Michael Burman 2017-08-31 08:41:22 EDT
Hi Lev,

ON_QA on which version?
Comment 5 Sandro Bonazzola 2017-09-01 05:26:33 EDT
Michael: 4.1.6.1
Comment 6 Michael Burman 2017-09-13 04:20:49 EDT
We decided to verify this RFE with the known issue described in BZ 1487930(see comment#18).
"Cisco is sending LLDP packets encapsulated in VLAN1, which is probably the native tag on the port. This is a known problem of Cisco devices."
- If using a cisco switch user must create a vlan tagged network with vlan tag 1 and only then lldp will be work for the port. 
- This should be added in the know issues of the release. 

Verified on - 4.1.6.2-0.1.el7

Dominik please make sure this will documented as part of the known issues in the release note.

Note You need to log in before you can comment on or make changes to this bug.