Bug 1479709 - templates quickswitch has the same name duplicated in the list
templates quickswitch has the same name duplicated in the list
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Alexander Wels
Petr Matyáš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 04:55 EDT by Lucie Leistnerova
Modified: 2017-12-20 05:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:51:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
switch_templates (19.40 KB, image/png)
2017-08-09 04:55 EDT, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81242 master POST webadmin: Template bread crumb display 2017-08-30 16:16 EDT

  None (edit)
Description Lucie Leistnerova 2017-08-09 04:55:36 EDT
Created attachment 1311066 [details]
switch_templates

Description of problem:
In switch box for templates appears more templates with the same name and it's not obvious which is a subversion of the original one.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170808202742.git7c42951.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. create template
2. create other one as subversion of the previous with same name
3. go to Templates, go to detail of some template
4. click in breadcrumb on the switch icon

Actual results: templates with the same name are shown, see attachment


Expected results: templates with name and version are shown
Comment 1 Tomas Jelinek 2017-08-14 03:23:52 EDT
Right, the template always has a name and a version and only this pair is unique. If you have more versions of the same template, the name is always the same.

The breadcrumb is a new feature introduced by UX - moving to UX to decide how to visualize the template versions in it.
Comment 2 Petr Matyáš 2017-09-07 08:32:22 EDT
Verified on ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos.noarch
Comment 3 Sandro Bonazzola 2017-12-20 05:51:45 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.