Bug 147972 - Freshen fails when there's two architectures of files being freshened
Freshen fails when there's two architectures of files being freshened
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 07:08 EST by Kaj J. Niemi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 11:35:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2005-02-14 07:08:31 EST
Description of problem:
Fails:
% rpm -Fvh *.rpm
warning: package glibc = 2.3.4-10 was already added, skipping glibc < 2.3.4-10
error: error reading from file glibc-2.3.4-10.i686.rpm

Works (no i386.rpm in the list):
rpm -Fvh glibc-2.3.4-10.i686.rpm glibc-common-2.3.4-10.i386.rpm
glibc-devel-2.3.4-10.i386.rpm glibc-headers-2.3.4-10.i386.rpm
glibc-profile-2.3.4-10.i386.rpm glibc-utils-2.3.4-10.i386.rpm
nptl-devel-2.3.4-10.i686.rpm nscd-2.3.4-10.i386.rpm


Version-Release number of selected component (if applicable):
rpm-4.4.1-0.22.i386

How reproducible:
Looks like always

Steps to Reproduce:
1. make sure there's a few files that need to be refreshened with different
architectures (say, i386, i686)
2. rpm -Fvh *.rpm
  
Actual results:
Fails

Expected results:
Shouldn't fail, this has worked since a long time :)
Comment 1 Jeff Johnson 2005-02-14 11:35:25 EST
Heh, "worked since a long time" is not at all the
same thing as correct. Several flaws have been fixed
in rpm-4.4.1 to exclude user/application errors seloecting
packages, choosing the latest package of the same name and arch in
rpmtsAddInstallElement().

--freshen is a very differnt problem case, and is broken in
several ways (i.e. epoch is not looked at, multilib choices
are not attempted, +/-NPTL wrto glibc not attempted).

I'd suggest using more specific input to rpm by doing
    ls -1 *.rpm
and filtering the package list appropriately.

Your final list can be fed firectly to rpm as
   rpm -Fvh manifest
rather than the splat you've been using.


Note You need to log in before you can comment on or make changes to this bug.