Bug 1479736 - Checking "all environments" on Organization edit page resets the assignment of the organization to the environment
Checking "all environments" on Organization edit page resets the assignment o...
Status: CLOSED DUPLICATE of bug 1321543
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations (Show other bugs)
6.2.10
Unspecified Unspecified
high Severity high (vote)
: Beta
: --
Assigned To: satellite6-bugs
: Triaged
: 1474249 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 06:00 EDT by Ivan Necas
Modified: 2017-10-06 18:26 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1474249
Environment:
Last Closed: 2017-09-21 13:56:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Necas 2017-08-09 06:00:17 EDT
How to reproduce:

1. assign puppet environment to organization
2. go to organization details, in environments check "All environments" button
3. go to environment details: the organization is unassigned from the organization.

With this behavior, checking the "all environments" lead to loosing the whole information about the originally assigned organization. Unchecking "all environments" later would end up with organization without environments.

Expected behaviour:

The organization assignments is preserved when the "all environments" is checked.

See https://bugzilla.redhat.com/show_bug.cgi?id=1474249 for consequences.
Comment 3 Ivan Necas 2017-08-22 09:58:07 EDT
*** Bug 1474249 has been marked as a duplicate of this bug. ***
Comment 4 Marek Hulan 2017-09-18 08:12:37 EDT
This will be probably fixed by BZ 1321543, we should retest when it's merged. We won't keep the history of what was assigned before but all environments will be associated. The issue described in 1474249 should not occur anymore.
Comment 5 Andrew Kofink 2017-09-21 13:56:09 EDT
I can confirm this is fixed with BZ 1321543.

*** This bug has been marked as a duplicate of bug 1321543 ***

Note You need to log in before you can comment on or make changes to this bug.