Bug 1479762 - Libreoffice will not start
Libreoffice will not start
Status: CLOSED DUPLICATE of bug 1468436
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 07:09 EDT by antonio montagnani
Modified: 2017-08-14 16:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-14 16:04:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2017-08-09 07:09:09 EDT
Description of problem:
Any component of libreoffice will not start

Version-Release number of selected component (if applicable):
5.3.4.2

How reproducible:
always when starting writer and/or calc

Steps to Reproduce:
1.start Libreoffice component
2.
3.

Actual results:
a black line is starting then freezes and crash

Expected results:
normal operation

Additional info:
it happens on a system , not another 3 systems...

Updated from 25 to 26
Comment 1 Caolan McNamara 2017-08-09 10:06:59 EDT
Is this i686 or x86_64 ? This might be the kernel + java libjvm bug
Comment 2 antonio montagnani 2017-08-09 14:52:25 EDT
(In reply to Caolan McNamara from comment #1)
> Is this i686 or x86_64 ? This might be the kernel + java libjvm bug

an 86_64 system, but disinstalling and re-installing libreoofice (the complete suite) makes it work. Another italian guy is affected exactly in the same way
Comment 3 JMlich 2017-08-14 16:01:47 EDT
I've experienced same problem after upgrade to Fedora26 (i686 arch).
Complete reinstallation of libreoffice fixed problem for me.

Prior reinstalling there was an crash in log as bellow; yes appears related to libjvm.

aug 14 21:35:27 fifi systemd-coredump[6060]: Process 6050 (soffice.bin) of user 1000 dumped core.
                                             
                                             Stack trace of thread 6050:
                                             #0  0x00000000a8c2ac95 _ZL16_expand_stack_toPh (libjvm.so)
                                             #1  0x00000000a8c2d75b _ZN2os5Linux21manually_expand_stackEP10JavaThreadPh (libjvm.so)
                                             #2  0x00000000a8c39d37 _ZN2os18create_main_threadEP10JavaThread (libjvm.so)
                                             #3  0x00000000a8d9e2d5 _ZN7Threads9create_vmEP14JavaVMInitArgsPb (libjvm.so)
                                             #4  0x00000000a89f6d15 JNI_CreateJavaVM (libjvm.so)
                                             #5  0x00000000b164066e _Z34jfw_plugin_startJavaVirtualMachinePK8JavaInfoPK12JavaVMOptionlPP7JavaVM_PP7JNIEnv_ (libjvmfwklo.so)
                                             #6  0x00000000b16525fd _Z11jfw_startVMPK8JavaInfoP12JavaVMOptionlPP7JavaVM_PP7JNIEnv_ (libjvmfwklo.so)
                                             #7  0x00000000a94ac60a _ZN11stoc_javavm18JavaVirtualMachine9getJavaVMERKN3com3sun4star3uno8SequenceIaEE (libjavavmlo.so)
                                             #8  0x00000000a94cf7e8 _ZN15stoc_javaloader19JavaComponentLoader13getJavaLoaderEv (libjavaloaderlo.so)
                                             #9  0x00000000a94d11b7 _ZN15stoc_javaloader19JavaComponentLoader17writeRegistryInfoERKN3com3sun4star3uno9ReferenceINS3_8registry12XRegistryKeyEEERKN3rtl8OUStringESE_ (libjavaloaderlo.so)
                                             #10 0x00000000a94f872d _ZN12_GLOBAL__N_126ImplementationRegistration10doRegisterERKN3com3sun4star3uno9ReferenceINS3_4lang22XMultiComponentFactoryEEERKNS5_INS4_17XComponentContextEEERKNS5_INS3_6loader21XImplementationLoaderEEERKNS5_INS3_8registry15XSimpleRegistryEEERKN3rtl8OUStringESS_SS_ (libbootstraplo.so)
                                             #11 0x00000000a94fac1e _ZN12_GLOBAL__N_126ImplementationRegistration15prepareRegisterERKN3rtl8OUStringES4_S4_RKN3com3sun4star3uno9ReferenceINS7_8registry15XSimpleRegistryEEE (libbootstraplo.so)
                                             #12 0x00000000a9a05313 _ZN11dp_registry7backend9component12_GLOBAL__N_111BackendImpl20ComponentPackageImpl15processPackage_ERN3osl15ResettableGuardINS5_5MutexEEEbbRKN3rtl9ReferenceIN7dp_misc12AbortChannelEEERKN3com3sun4star3uno9ReferenceINSJ_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #13 0x00000000a9a26ecf _ZN11dp_registry7backend7Package19processPackage_implEbbRKN3com3sun4star3uno9ReferenceINS4_4task13XAbortChannelEEERKNS6_INS4_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #14 0x00000000a9a276ff _ZN11dp_registry7backend7Package15registerPackageEhRKN3com3sun4star3uno9ReferenceINS4_4task13XAbortChannelEEERKNS6_INS4_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #15 0x00000000a9a515cb _ZN11dp_registry7backend6bundle12_GLOBAL__N_111BackendImpl11PackageImpl15processPackage_ERN3osl15ResettableGuardINS5_5MutexEEEbbRKN3rtl9ReferenceIN7dp_misc12AbortChannelEEERKN3com3sun4star3uno9ReferenceINSJ_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #16 0x00000000a9a26ecf _ZN11dp_registry7backend7Package19processPackage_implEbbRKN3com3sun4star3uno9ReferenceINS4_4task13XAbortChannelEEERKNS6_INS4_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #17 0x00000000a9a276ff _ZN11dp_registry7backend7Package15registerPackageEhRKN3com3sun4star3uno9ReferenceINS4_4task13XAbortChannelEEERKNS6_INS4_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #18 0x00000000a99d3846 _ZN10dp_manager16ExtensionManager17activateExtensionERKN3com3sun4star3uno8SequenceINS4_9ReferenceINS3_10deployment8XPackageEEEEEbbRKNS6_INS3_4task13XAbortChannelEEERKNS6_INS3_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #19 0x00000000a99d5ea2 _ZN10dp_manager16ExtensionManager11synchronizeERKN3com3sun4star3uno9ReferenceINS3_4task13XAbortChannelEEERKNS5_INS3_3ucb19XCommandEnvironmentEEE (libdeployment.so)
                                             #20 0x00000000b67ff27a _ZN7dp_misc16syncRepositoriesEbRKN3com3sun4star3uno9ReferenceINS2_3ucb19XCommandEnvironmentEEE (libdeploymentmisclo.so)
                                             #21 0x00000000b76d37d5 _ZN7desktop7Desktop32SynchronizeExtensionRepositoriesEv (libsofficeapp.so)
                                             #22 0x00000000b76c5802 _ZN7desktop7Desktop4MainEv (libsofficeapp.so)
                                             #23 0x00000000b430e1e2 _Z10ImplSVMainv (libvcllo.so)
                                             #24 0x00000000b430e319 _Z6SVMainv (libvcllo.so)
                                             #25 0x00000000b76fbd35 soffice_main (libsofficeapp.so)
                                             #26 0x00000000800e35cc main (soffice.bin)
                                             #27 0x00000000b74b12f3 __libc_start_main (libc.so.6)
                                             #28 0x00000000800e360f _start (soffice.bin)
Comment 4 Michael Stahl 2017-08-14 16:04:11 EDT

*** This bug has been marked as a duplicate of bug 1468436 ***

Note You need to log in before you can comment on or make changes to this bug.