Bug 1479778 - Azureus 5.7.4.0.3 fails to start on F26 - With workaround
Azureus 5.7.4.0.3 fails to start on F26 - With workaround
Status: CLOSED DUPLICATE of bug 1471578
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Juran
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 07:42 EDT by Anthony Name
Modified: 2017-08-20 18:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-20 18:42:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to get azureus to look for the swt.jar and other libraries in the 32bit library directory namely /usr/lib/eclipse (338 bytes, patch)
2017-08-15 09:59 EDT, Vinu Moses
no flags Details | Diff

  None (edit)
Description Anthony Name 2017-08-09 07:42:02 EDT
Description of problem:
Machine was updated from F25x64 to F26x64 via DNF upgrade about a month ago, Azureus worked fine on F25x64 and F26x64.  Did my monthly DNF update yesterday and Azureus now won't start.

Upon research found that swt.jar is now being forced to be found in /usr/lib64/eclipse whereas it's in /usr/lib/eclipse.

Create /usr/lib64/eclipse and in it create a Symbolic link to /usr/lib/eclipse/swt.jar fixes the problem. 

Version-Release number of selected component (if applicable):
F26, Azureus 5.7.4.0.3

How reproducible:
azureus fails to start

Steps to Reproduce:
1. see above
2.
3.

Actual results:
borks

Expected results:
azureus starts

Additional info:
see above for workaround
Comment 1 Vinu Moses 2017-08-15 09:59 EDT
Created attachment 1313708 [details]
Patch to get azureus to look for the swt.jar and other libraries in the 32bit library directory namely /usr/lib/eclipse

Based on the solution suggested in https://bugzilla.redhat.com/show_bug.cgi?id=1471578 I have modified the f26 azureus binary slightly to make it work.
Comment 2 Sergio Monteiro Basto 2017-08-20 18:42:09 EDT

*** This bug has been marked as a duplicate of bug 1471578 ***

Note You need to log in before you can comment on or make changes to this bug.