Bug 1479779 - add template version in networks Template subtab to differentiate between subversions
add template version in networks Template subtab to differentiate between sub...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.2.0
: ---
Assigned To: Ales Musil
Lucie Leistnerova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 07:42 EDT by Lucie Leistnerova
Modified: 2017-12-20 05:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:53:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)
network_templates (37.78 KB, image/png)
2017-08-10 02:23 EDT, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80594 master MERGED webadmin: Add template version in networks Template subtab 2017-08-22 10:30 EDT

  None (edit)
Description Lucie Leistnerova 2017-08-09 07:42:49 EDT
Description of problem:
In network subtab Templates it doesn't differ between subversion and original template. So there are many lines with the same name.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170808202742.git7c42951.el7.centos.noarch

How reproducible: always


Steps to Reproduce:
1. create template and its subversion from the same VM
2. go to Network -> Networks
3. go to detail of appropriate network that the templates use
4. go to Templates subtab

Actual results: more lines with same name, no version difference


Expected results: more lines with same name and different versions


Additional info:
Same is in vNIC profiles subtab Templates.
Comment 1 Dan Kenigsberg 2017-08-09 16:07:55 EDT
Can you attach a screenshot, please?
Comment 2 Lucie Leistnerova 2017-08-10 02:23 EDT
Created attachment 1311601 [details]
network_templates

Sure, here it is.
Comment 3 Dan Kenigsberg 2017-08-14 04:35:37 EDT
the requested template version column should immediately follow the template name column.

the table should be sorted by (name, version, vnic).
Comment 4 Lucie Leistnerova 2017-09-01 06:42:45 EDT
Version column added, default sorting is alright.

I created new Bug 1487584 for missing head separator 

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20170831223128.git34f4d69.el7.centos.noarch
Comment 5 Sandro Bonazzola 2017-12-20 05:53:47 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.