Bug 1479782 - Missing images definition in tripleo heat template.
Missing images definition in tripleo heat template.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity low
: ---
: 12.0 (Pike)
Assigned To: Dan Prince
Gurenko Alex
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 07:46 EDT by Sofer Athlan-Guyot
Modified: 2017-10-20 09:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-20 09:12:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sofer Athlan-Guyot 2017-08-09 07:46:39 EDT
Description of problem:  When deploying osp12 you have to download the correct image definition file to be able to run a containerized deployment.

Currently that looks like this:


REPO="$(find /etc/yum.repos.d/ -iname 'rhos-release-??.*')"
REPO_URL="$(grep -B2 enabled=1 $REPO | grep -m1 puddle | sed -E 's/.*(http.*[0-9]-RHEL-.\/).*/\1/')"
curl -L -o  {{ containers_default_parameters }} $REPO_URL/last_containers/docker-osp12.yaml

Could it be possible to have it packaged in tht as it is currently the case for upstream (in /usr/share/openstack-tripleo-heat-templates/environments/docker-centos-tripleoupstream.yaml)


Version-Release number of selected component (if applicable): openstack-tripleo-heat-templates-7.0.0-0.20170803094851.el7ost.noarch
Comment 1 Omri Hochman 2017-08-16 09:14:47 EDT
Hi Sofer  -  

we have now the prepare command creating this file -> 

TAG=`curl http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/12.0-RHEL-7/latest_containers/container_images.yaml|awk -F':' '/imagename/ {print $NF; exit}'`

openstack overcloud container image prepare --namespace=docker-registry.engineering.redhat.com/rhosp12 --env-file=/home/stack/rhos12.yaml --prefix=openstack- --suffix=-docker --tag=$TAG 


Can you check if that answering the requirement ?
Comment 2 Sofer Athlan-Guyot 2017-08-18 04:10:54 EDT
Hi Omri,

not super user friendly and I still don't see why it's not package with tht as the upstream is.  The only way this could be useful (image tag not synch with tht package) would be to give the user to update the docker image without updating the tht template. This would be another update procedure.  Or am I missing something.
Comment 3 Dan Prince 2017-10-20 09:12:37 EDT
Closing as now we are using the 'openstack overcloud container image prepare' command to generate this environment file.

Note You need to log in before you can comment on or make changes to this bug.