Bug 1479785 - No Connectivity from an instance without Floating IP to an instance with Floating IP
Summary: No Connectivity from an instance without Floating IP to an instance with Floa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Aswin Suryanarayanan
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-09 12:00 UTC by Itzik Brown
Modified: 2018-10-18 07:19 UTC (History)
6 users (show)

Fixed In Version: opendaylight-8.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:33:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight Bug 8964 None None None 2017-08-09 12:00:44 UTC
OpenDaylight gerrit 62938 None None None 2017-09-20 13:28:09 UTC
OpenDaylight gerrit 63944 None None None 2017-10-04 15:04:00 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:45 UTC

Description Itzik Brown 2017-08-09 12:00:45 UTC
Description of problem:
When running the scenario test neutron.tests.tempest.scenario.test_floatingip.FloatingIpSameNetwork.test_east_west it fails running the scenario of connecting from an instance without a Floating IP to another instance floating IP

2017-08-09 07:50:16.386 16141 INFO tempest.lib.common.ssh [-] Creating ssh connection to '10.100.0.6:22' as 'root' with public key authentication
2017-08-09 07:50:16.387 16141 INFO tempest.lib.common.ssh [-] Creating ssh connection to '10.0.0.231:22' as 'root' with public key authentication
2017-08-09 07:50:16.449 16141 INFO paramiko.transport [-] Connected (version 2.0, client OpenSSH_6.6.1)
2017-08-09 07:50:16.598 16141 INFO paramiko.transport [-] Authentication (publickey) successful!
2017-08-09 07:50:16.600 16141 INFO tempest.lib.common.ssh [-] ssh connection to root@10.0.0.231 successfully created
2017-08-09 07:50:17.159 16141 INFO paramiko.transport [-] Connected (version 2.0, client OpenSSH_6.6.1)
2017-08-09 07:50:17.377 16141 INFO paramiko.transport [-] Authentication (publickey) successful!
2017-08-09 07:50:17.409 16141 INFO tempest.lib.common.ssh [-] ssh connection to root@10.100.0.6 successfully created
2017-08-09 07:50:18.559 16141 WARNING neutron.tests.tempest.scenario.base [-] Failed to ping IP: 10.0.0.224 via a ssh connection from: 10.100.0.6.: SSHExecCommandFailed: Command 'ping -c1 -w1 -s56 10.0.0.224', exit status: 1, stderr:

stdout:
PING 10.0.0.224 (10.0.0.224) 56(84) bytes of data.

--- 10.0.0.224 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 999ms


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2017-08-09 12:01:44 UTC
Version: opendaylight-6.1.0-2.el7ost.noarch

Comment 2 Itzik Brown 2017-08-09 12:21:40 UTC
The test launches 3 instances - 2 with floating IPs and one without Floating IP.

One of the use cases is SSH to one of the instances with a FloatingIP and from there SSH to the instance without FloatingIP (using the internal network). Then running ping to the Floating IP address of the Third machine.

In the description the IP of the source instance (the one we are pinging from) is 10.100.0.6 and the Destination is 10.0.0.224.

Comment 3 Itzik Brown 2017-08-09 12:32:43 UTC
The 3 instances belongs to one tenant and there are security groups that allow SSH and ICMP from any.

Comment 4 Tim Rozet 2017-09-08 15:33:48 UTC
What kind of deployment is this 3 controllers+ODL, and 2 computes?

Comment 5 Itzik Brown 2017-09-10 10:07:55 UTC
AFAIR 1 controller and 2 compute nodes.

Comment 8 Itzik Brown 2018-02-22 09:07:15 UTC
Aswin,
I see that the patches are merged.
If so - Please move it to POST.

Comment 10 Itzik Brown 2018-03-18 12:14:35 UTC
Verified with:
opendaylight-8.0.0-2.el7ost.noarch.rpm

Comment 15 errata-xmlrpc 2018-06-27 13:33:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.