Bug 1479804 - Build documentation for openstack-swift fails with python-docutils-0.11
Build documentation for openstack-swift fails with python-docutils-0.11
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-docutils (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Charalampos Stratakis
Maryna Nalbandian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 08:28 EDT by Alfredo Moralejo
Modified: 2018-04-10 11:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-docutils-0.11-0.3.20130715svn7687.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 11:28:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0859 None None None 2018-04-10 11:28 EDT

  None (edit)
Description Alfredo Moralejo 2017-08-09 08:28:52 EDT
Description of problem:

When building documentation for openstack-swift following error message appears:

Warning, treated as error:
/tmp/swift/doc/source/deployment_guide.rst:815: (ERROR/3) Malformed table.
Column span alignment problem in table line 13.

===========================  ========================  ================================
Option                       Default                   Description
---------------------------  ------------------------  --------------------------------
log_name                     object-reconstructor      Label used when logging
log_facility                 LOG_LOCAL0                Syslog log facility
log_level                    INFO                      Logging level

.....

Version-Release number of selected component (if applicable):

python-docutils-0.11-0.2.20130715svn7687.el7.noarch

How reproducible:

allways

Steps to Reproduce:
1. Enable RDO repos
2. yum-builddep openstack-swift
3. git clone http://github.com/openstack/swift
4. cd swift
5. python ./setup.py build_sphinx -b html

Actual results:

A error appears:

Warning, treated as error:
/var/tmp/packstack/20170809-062249-KSXgfH/swift/doc/source/deployment_guide.rst:815: (ERROR/3) Malformed table.
Column span alignment problem in table line 13.

===========================  ========================  ================================
Option                       Default                   Description
---------------------------  ------------------------  --------------------------------
log_name                     object-reconstructor      Label used when logging
log_facility                 LOG_LOCAL0                Syslog log facility
...

Expected results:

It should build the doc with no errors

Additional info:

Command success with docutils-1.13.1.

The commit that fixed this is https://sourceforge.net/p/docutils/code/7898/
Comment 2 Alfredo Moralejo 2017-08-09 08:30:55 EDT
(In reply to Alfredo Moralejo from comment #0)

> 
> Additional info:
> 
> Command success with docutils-1.13.1.
> 

I meant docutils==0.13.1

> The commit that fixed this is https://sourceforge.net/p/docutils/code/7898/
Comment 3 Petr Viktorin 2017-08-23 08:21:25 EDT
This looks like an easy enough backport, from the eng point of view.
However, it looks it can be worked around by extending the table source's header lines, or word-wrapping the content so it doesn't extend past the lines.
Comment 8 errata-xmlrpc 2018-04-10 11:28:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0859

Note You need to log in before you can comment on or make changes to this bug.