Bug 1479836 - Include new cockpit-packagekit subpackage into RHEL 7 Extras
Include new cockpit-packagekit subpackage into RHEL 7 Extras
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Martin Pitt
qe-baseos-daemons
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 10:08 EDT by Martin Pitt
Modified: 2017-10-19 11:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-19 11:18:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pitt 2017-08-09 10:08:32 EDT
Two months ago Cockpit introduced a new "Software Updates" page for "classic" RPM (and deb) based systems [1]. So far we have only had a "Software Updates" page on Atomic based systems (cockpit-ostree).

This has been improved and matured since then (user testing, subscription detection, etc.) and has been shipped in Fedora 26, Debian and Ubuntu stable releases, so it did get some field testing. I think it is mature enough to get included into RHEL Extras now.

Note that the UI will grow in the future, e. g. to add support for configuring automatic updates or exposing repository information (see the spec [2]). As with the rest of cockpit in extras this package would see frequent rebases and thus deliver these new features.

[1] http://cockpit-project.org/blog/cockpit-143.html
[2] https://github.com/cockpit-project/cockpit/wiki/Feature:-System-Updates-for-dnf,-yum,-apt-hosts
Comment 6 Oneata Mircea Teodor 2017-09-07 09:54:13 EDT
Hello all,

Please find at this link the documentation on how to handle zstreams.
https://mojo.redhat.com/docs/DOC-1021938#jive_content_id_Processing_a_ZStream_fix

Also this bug needs also 7.5 flag, we cannot clone directly 7.4z stream.
Comment 7 Peter 2017-09-07 10:04:52 EDT
@Oneata, the point of this is to release a subpackage in rhel 7.4 extras, not 7.5 or 7.5 extras. Because this is not a new package, just releasing a subpackage that we were previously filtering out with whitelists, we've gotten the ok to do this.
Comment 8 Oneata Mircea Teodor 2017-09-07 10:10:02 EDT
(In reply to Peter from comment #7)
> @Oneata, the point of this is to release a subpackage in rhel 7.4 extras,
> not 7.5 or 7.5 extras. Because this is not a new package, just releasing a
> subpackage that we were previously filtering out with whitelists, we've
> gotten the ok to do this.

OK than, no process for extra zstream. If you have a QE assigned request the ack from him for qa_ack.
I'll provide ack for 7.4z after.
Comment 9 Martin Pitt 2017-09-07 10:15:31 EDT
Jan, can you please review this and set the QA ack? This new package is covered by our CI, and I'm happy to answer any questions about it (on IRC or here) wrt. what it does, how to test it manually, etc.
Comment 10 Djordje Todorovic 2017-09-08 08:21:42 EDT
@toneata,

Hello sir, we have the qa_ack+. Can you please review and give us official 7.4z blessing.

Thanks!
Comment 11 Oneata Mircea Teodor 2017-09-08 08:24:58 EDT
(In reply to Djordje Todorovic from comment #10)
> @toneata,
> 
> Hello sir, we have the qa_ack+. Can you please review and give us official
> 7.4z blessing.
> 
> Thanks!

Hello,

Done.
Comment 12 Djordje Todorovic 2017-09-08 09:35:28 EDT
cockpit-packagekit subpackage has been added to compose config for Extras-RHEL-7.4.

https://code.engineering.redhat.com/gerrit/#/c/117645/
Comment 16 errata-xmlrpc 2017-10-19 11:18:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2961

Note You need to log in before you can comment on or make changes to this bug.