Bug 1479838 - Wrong matching for LUN disks
Wrong matching for LUN disks
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Arik
Kevin Alon Goldblatt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 10:17 EDT by Arik
Modified: 2017-12-20 05:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:52:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+
ahadas: devel_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80533 master MERGED core: fix matching of lun disks 2017-08-16 04:09 EDT

  None (edit)
Description Arik 2017-08-09 10:17:27 EDT
Description of problem:
In 4.2, the matching of the devices reported form libvirt with those defined in the database was moved from vdsm to the engine. But the logic that was introduced for matching the disks is incomplete. It is done according to the 'path' of the disk (like VDSM used to do), but assumes the following logic: the path must contain the disk id. 
However, this logic doesn't hold for LUN disks since their path is composed of "/dev/mapper/<lun_id>". Thus, we need to extend the matching logic for LUN disks, to base on the lun_id instead.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run a VM with a plugged LUN disk
2. 
3.

Actual results:
The LUN disk is being unplugged in the engine database

Expected results:
The LUN disk should remain plugged

Additional info:
If the disk is plugged after being unplugged in a previous run of the VM, the VM will start and the LUN disk will remain plugged. So in order to reproduce this bug, we'll need to enforce the devices hash to change by, for example, plugging a NIC.
Comment 1 Arik 2017-08-09 10:19:20 EDT
The fix is supposed to be relatively easy but it needs to be verified with LUN disks so this better gets handled by the storage team.
Comment 2 Red Hat Bugzilla Rules Engine 2017-08-14 04:35:05 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Kevin Alon Goldblatt 2017-11-28 12:09:54 EST
Verified with the following code:
-------------------------------------------
ovirt-engine-4.2.0-0.5.master.el7.noarch
vdsm-4.20.8-53.gitc3edfc0.el7.centos.x86_64

Verified with the following scenario:
-------------------------------------------
1. Created a vm, attached a direct LUN to the VM (LUN is plugged)
2. Started the vm (LUN is plugged)
3. Added nic (LUN remains plugged)


Moving to VERIFIED
Comment 4 Sandro Bonazzola 2017-12-20 05:52:41 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.