This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 147984 - /sbin/lvm no more: system-config-lvm breaks
/sbin/lvm no more: system-config-lvm breaks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-14 10:16 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-05 13:24:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-02-14 10:16:14 EST
Description of problem:
system-config-lvm throws an exception and aborts at start up because
it can't run /sbin/lvm.  lvm2 no longer provides such a binary; it's
either /sbin/lvm.static or /usr/sbin/lvm.  All of the occurrences are
in lvm_model.py.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.18-1.1

How reproducible:
Always
Comment 1 Jim Cornette 2005-02-17 18:22:38 EST
I am also experiencing this problem with a system that was upgraded
from FC3 to rawhide on Feb 13,2005.
The version is the same as listed above.

 Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 131, in ?
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 116, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 70, in __init__
    self.volume_tab_view = Volume_Tab_View(glade_xml, self.lvmm,
self.main_win)
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 131, in
__init__
    self.prepare_tree()
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 203, in
prepare_tree
    vg_list = self.model_factory.query_VGs()
  File "/usr/share/system-config-lvm/lvm_model.py", line 314, in query_VGs
    result_string = rhpl.executil.execWithCapture("/sbin/lvm",arglist)
  File "/usr/lib/python2.4/site-packages/rhpl/executil.py", line 105,
in execWithCapture
    raise RuntimeError, command + " can not be run"
RuntimeError: /sbin/lvm can not be run


lvm itself is functional. I was able to run commands without errors.

....
Comment 2 Jim Cornette 2005-02-17 20:34:23 EST
Adding a symlink from /usr/sbin/lvm to /sbin/lvm allows the program to
come up and display the lvm information.

I don't know whether lvm is in the wrong location or the script is
looking in the wrong place.
Comment 3 Jim Parsons 2005-04-06 10:38:08 EDT
The reason for this defect is because the link from /usr/sbin/lvm to /sbin/lvm
was  dropped in a recent distribution of the underlying LVM2 application. This
link has been restored, however, and should  work correctly with the next fedora
release. In the meanwhile, making this link above by hand addresses the issue
immediately.
Comment 6 Jim Parsons 2005-04-06 13:05:40 EDT
Changed path in application to /usr/sbin/lvm. Fixed in system-config-lvm >= 0.9.21
Comment 7 Alexandre Oliva 2005-05-05 13:24:23 EDT
Seems to work now, but it's extremely noisy in the output to the initiating
console, at least with selinux enabled.  It prints messages such as:

File descriptor 7 left open
File descriptor 8 left open
File descriptor 9 left open
File descriptor 10 left open
File descriptor 11 left open
File descriptor 12 left open
File descriptor 13 left open
File descriptor 14 left open

a nearly-infinite number of times.  I guess this is something for a separate bug
report though.

Note You need to log in before you can comment on or make changes to this bug.