Bug 1479842 - python-TurboMail: Missing build-time dependency on python2-devel
python-TurboMail: Missing build-time dependency on python2-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-TurboMail (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 10:30 EDT by Iryna Shcherbina
Modified: 2017-08-24 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-TurboMail-3.0.3-14.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-24 08:52:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add a build-time dependency on python2-devel (2.13 KB, patch)
2017-08-09 10:30 EDT, Iryna Shcherbina
no flags Details | Diff

  None (edit)
Description Iryna Shcherbina 2017-08-09 10:30:47 EDT
Created attachment 1311241 [details]
Add a build-time dependency on python2-devel

A build-time dependency on python2-devel is missing.

This is the reason why the dependency on Python itself is not generated for python-TurboMail-0:3.0.3-12.fc27:

$ dnf repoquery --disablerepo=* --enablerepo=rawhide --requires python-TurboMail | grep python
python-setuptools


According to Fedora Packaging Guidelines for Python [0], packages building for Python 2 need BuildRequires: python2-devel.

I have attached the patch which adds a missing build-time dependency. Please review it and apply.

[0] https://fedoraproject.org/wiki/Packaging:Python#Dependencies
Comment 1 Dan Callaghan 2017-08-14 02:25:19 EDT
Thanks for the patch, looks fine to me.

lmacken seems to have stopped maintaining his Fedora packages since he left Red Hat. I filed a PR with this patch:

https://src.fedoraproject.org/rpms/python-TurboMail/pull-request/1

If nobody objects in the new few days I'll merge it and build for rawhide.
Comment 2 Jan Kurik 2017-08-15 04:30:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 3 Iryna Shcherbina 2017-08-15 18:11:54 EDT
Thanks Dan.

Note You need to log in before you can comment on or make changes to this bug.