Bug 1479862 - virt-manager-1.4.2 still requires obsolete gnome-icon-theme
virt-manager-1.4.2 still requires obsolete gnome-icon-theme
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 11:14 EDT by Pacho Ramos
Modified: 2017-08-09 16:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 16:47:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pacho Ramos 2017-08-09 11:14:54 EDT
As I read in provided .spec file under 1.4.2 tarball, it seems 1.4.2 version is still requiring to install the obsolete gnome-icon-theme package instead of adwaita (or other XDG compliant icon sets). It would be nice to finally drop that requirement to allow us to kill the old icon set.

Thanks a lot
Comment 1 Cole Robinson 2017-08-09 11:37:43 EDT
It only requires gnome-icon-theme on RHEL7. Are you using rhel or centos? 

The original bug that prompted adding that dep is:

https://bugzilla.redhat.com/show_bug.cgi?id=1146612

So we need to make sure that's not valid anymore, it may not be since rhel7 has updated the gtk3 version since then
Comment 2 Pacho Ramos 2017-08-09 16:47:02 EDT
I am using it for Gentoo... I mean, we still have our ebuild adding gnome-icon-theme as RDEPEND and I tried to check if we could drop its dep in favor of any newer icon set. 

Indeed, I see that .spec file that it's only for RHEL7. I will check to drop it :)

Thanks!
Comment 3 Pacho Ramos 2017-08-09 16:52:47 EDT
It looks to also work fine or, at least, I still didn't find any missing icon

Note You need to log in before you can comment on or make changes to this bug.