Bug 1479864 - Upgrade perl-Net-SSH-Perl to 2.12
Upgrade perl-Net-SSH-Perl to 2.12
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Net-SSH-Perl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
: FutureFeature
Depends On: 1546648
Blocks: 1479860
  Show dependency treegraph
 
Reported: 2017-08-09 11:23 EDT by Jitka Plesnikova
Modified: 2018-02-26 10:06 EST (History)
2 users (show)

See Also:
Fixed In Version: perl-Net-SSH-Perl-2.14-1.fc28 perl-Net-SSH-Perl-2.14-1.fc29
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-26 10:06:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Plesnikova 2017-08-09 11:23:28 EDT
Latest Fedora delivers 1.42 version. Upstream released 2.12. When you have free time, please upgrade it.

The latest version is required for Net-SFTP-0.12.
Comment 1 Paul Howarth 2017-08-09 11:33:00 EDT
Net-SSH-Perl 2.x depends on CryptX, which bundles libtomcrypt.

Denis Fateyev did show some interest in packaging CryptX but the discussion seemed to tail off around November last year:

https://lists.fedoraproject.org/archives/list/perl-devel@lists.fedoraproject.org/message/P5AYS75L4ENHGWP4MMYIFZ3GMPLOWE2N/

Unless someone is willing to package CryptX, Net-SSH-Perl will be stuck at 1.42.
Comment 2 Paul Howarth 2018-02-26 10:06:54 EST
I have now update perl-Net-SSH-Perl to 2.14 in F-28 and Rawhide, albeit hobbled somewhat due to missing ECC support in perl-CryptX (Bug #1545816).

F-28 build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25322353

Rawhide build:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25322031

I've tested that I can use the eg/pssh script to access some of my machines but the hobbling process may result in some broken behavior that I haven't spotted.

Note You need to log in before you can comment on or make changes to this bug.