Bug 1479869 - Delete Cinder disk fails [due to jboss executor service change?]
Delete Cinder disk fails [due to jboss executor service change?]
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ravi Nori
Petr Matyáš
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 11:30 EDT by Fred Rolland
Modified: 2017-12-20 06:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:33:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)
Thread dump (365.60 KB, text/plain)
2017-08-30 03:06 EDT, Fred Rolland
no flags Details
engine log (268.01 KB, text/plain)
2017-08-30 03:11 EDT, Fred Rolland
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81535 master POST engine: Delete Cinder disk fails 2017-09-06 11:40 EDT

  None (edit)
Description Fred Rolland 2017-08-09 11:30:57 EDT
Description of problem:

Cannot delete a Cinder disk.
The operation never finishes.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Delete a Cinder Disk
2.
3.

Actual results:
Operation never finishes


Expected results:
Operation finish successfuly

Additional info:
Nothing in the logs
Comment 1 Fred Rolland 2017-08-30 03:06 EDT
Created attachment 1319884 [details]
Thread dump
Comment 2 Fred Rolland 2017-08-30 03:11 EDT
Created attachment 1319886 [details]
engine log
Comment 3 Fred Rolland 2017-08-30 03:22:03 EDT
It looks like an Infra issue.
I tried this flow on the master, starting from the patch before https://gerrit.ovirt.org/#/c/73606/18 and it worked OK.

In the attached engine log, there is a successful run from before the patch, and after it a failing one with master including the patch.

In this flow , the RemoveDiskCommand calls RemoveCinderDiskCommands that calls RemoveCinderDiskVolumeCommand that is not invoked.
Comment 4 Petr Matyáš 2017-10-11 08:36:34 EDT
Verified on ovirt-engine-4.2.0-0.0.master.20171010112017.gita8289d1.el7.centos.noarch
Comment 5 Sandro Bonazzola 2017-12-20 06:33:59 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.