Bug 1479885 - /api/environments search ignores organization/location
/api/environments search ignores organization/location
Status: CLOSED DUPLICATE of bug 1472863
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: satellite6-bugs
Katello QA List
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-08-09 12:06 EDT by Stanislav Tkachenko
Modified: 2017-08-31 07:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-31 07:08:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Tkachenko 2017-08-09 12:06:42 EDT
Description of problem:
When searching for environment using exisiting organization/location as filtering criteria, it shows all environments. I've tried both name and id.

API, CLI and UI are affected.

First organization, all envs are listed:
> # hammer -u admin -p changeme environment list --search="organization=ldEfUWXqQE"
> ---|---------------------------------------
> ID | NAME                                  
> ---|---------------------------------------
> 2  | KT_EidanSPSEn_Library_lKlWziXRrT_78   
> 3  | KT_EidanSPSEn_SEIOiZvPNz_lKlWziXRrT_78
> 4  | KT_ldEfUWXqQE_Library_QWHvgzxtPg_81   
> 5  | KT_ldEfUWXqQE_MpMGDbtpLh_QWHvgzxtPg_81
> 1  | production                            
> ---|---------------------------------------

Second organization, all envs are listed:
> # hammer -u admin -p changeme environment list --search="organization=EidanSPSEn"
> ---|---------------------------------------
> ID | NAME                                  
> ---|---------------------------------------
> 2  | KT_EidanSPSEn_Library_lKlWziXRrT_78   
> 3  | KT_EidanSPSEn_SEIOiZvPNz_lKlWziXRrT_78
> 4  | KT_ldEfUWXqQE_Library_QWHvgzxtPg_81   
> 5  | KT_ldEfUWXqQE_MpMGDbtpLh_QWHvgzxtPg_81
> 1  | production

# Org id
> # hammer -u admin -p changeme organization info --name="EidanSPSEn"
> Id:                     48
> # hammer -u admin -p changeme environment list --search="organization_id=48"
> ---|---------------------------------------
> ID | NAME                                  
> ---|---------------------------------------
> 2  | KT_EidanSPSEn_Library_lKlWziXRrT_78   
> 3  | KT_EidanSPSEn_SEIOiZvPNz_lKlWziXRrT_78
> 4  | KT_ldEfUWXqQE_Library_QWHvgzxtPg_81   
> 5  | KT_ldEfUWXqQE_MpMGDbtpLh_QWHvgzxtPg_81
> 1  | production                            
                            
However, environment associated only with one organization
> # hammer -u admin -p changeme environment info --id=2
> Id:            2
> Name:          KT_EidanSPSEn_Library_lKlWziXRrT_78
> Puppetclasses: 
>    access_insights_client
> Locations:     
>    Default Location
> Organizations: 
>    EidanSPSEn


Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 10:
* satellite-6.3.0-16.0.beta.el7sat.noarch
* katello-3.4.4-2.el7sat.noarch
* foreman-1.15.2-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create organization/location
2. Associate environment with that organization/location
3. Create another organization/location that has now associations with environments
4. Filter environments by the second organization/location

Actual results:
All environments are listed.

Expected results:
Only environments that associated with that organization/location

Additional info:
Comment 3 Marek Hulan 2017-08-29 02:34:38 EDT
This is very likely the same bug as tracked under BZ 1472863.
Comment 4 Ondřej Pražák 2017-08-31 07:08:45 EDT
Yes, the fix for BZ 1472863 takes care of this as well, closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1472863 ***

Note You need to log in before you can comment on or make changes to this bug.